Bug 179321 - Anaconda creates link /etc/X11/X to non-existing file
Summary: Anaconda creates link /etc/X11/X to non-existing file
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-30 10:23 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 15:15:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2006-01-30 10:23:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Epiphany/1.9.5.1

Description of problem:
After installation from the rawhide tree as of 2006/01/27, a
non-existing link

  /etc/X11/X -> ../../usr/X11R6/bin/Xorg

is created.

Version-Release number of selected component (if applicable):
anaconda-10.91.8-1

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora from the rawhide tree.
2. Check content of /etc/X11.

  

Actual Results:  "X" points to "/usr/X11R6/bin/Xorg".

Expected Results:  "X" should point to "/usr/bin/Xorg".

Additional info:

A post-firstboot run of "system-config-display-1.0.36-1" creates
the correct link. Because that is the version of the original
package, the wrong link does not seem to have been created by
"system-config-display-1.0.36-1" during the firstboot setup
procedure.

The absent of the right link does not seem to trigger any negative
effect though.


Note You need to log in before you can comment on or make changes to this bug.