Bug 1793250 - Build llvm-9.0.1-3.fc32 has a gigantic llvm-libs file included
Summary: Build llvm-9.0.1-3.fc32 has a gigantic llvm-libs file included
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: llvm
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom Stellard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-21 00:36 UTC by Brian Lane
Modified: 2020-01-22 03:40 UTC (History)
10 users (show)

Fixed In Version: llvm-9.0.1-4.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-22 03:40:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Brian Lane 2020-01-21 00:36:12 UTC
Description of problem:
Nightly compose is failing with out of space errors for the rootfs.

Version-Release number of selected component (if applicable):
 llvm-9.0.1-3.fc32

How reproducible:
Always

Take a look at the file sizes here:

https://koji.fedoraproject.org/koji/rpminfo?rpmID=20087139

/usr/lib64/libLLVM-9.so is far larger than expected. IIRC this has happened before, causing the same problem with lorax and pungi. It might be time to add a test to the llvm build to check for this :)

Comment 1 Tom Stellard 2020-01-21 00:49:16 UTC
It looks like the libLLVM.so library wasn't stripped on x86_64.  I'm trying to figure out why this failed.

Comment 2 Tom Stellard 2020-01-21 00:51:31 UTC
Ok, I found it.  It looks like disk space ran out while trying to strip the binaries, but the build continued:

objcopy:/builddir/build/BUILDROOT/llvm-9.0.1-3.fc32.x86_64/usr/lib64/stPz9Ds6[.debug_info]: No space left on device
objcopy:/builddir/build/BUILDROOT/llvm-9.0.1-3.fc32.x86_64/usr/lib64/stPz9Ds6[.gdb_index]: No space left on device
eu-strip: while writing '/builddir/build/BUILDROOT/llvm-9.0.1-3.fc32.x86_64/usr/lib/debug/usr/lib64/libLLVM-9.so-9.0.1-3.fc32.x86_64.debug.qLSUNA': cannot write data to file


I can try to do a new build, but this is really a bug in the build system, because the build should fail in this case.

Comment 3 Kevin Fenzi 2020-01-21 03:33:35 UTC
Sounds like a bug in strip? It should exit with an error there you would think?

I've untagged the large build for now.

Comment 4 Tom Stellard 2020-01-22 03:40:04 UTC
I added a gating test to check the object size and rebuilt the package and this time it was successfull.  I also filed a bug against rpm: https://bugzilla.redhat.com/show_bug.cgi?id=1793746


Note You need to log in before you can comment on or make changes to this bug.