Bug 17934 - rhnsd should not run by default
rhnsd should not run by default
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-30 00:17 EDT by Daniel Roesen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-02 23:07:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Roesen 2000-09-30 00:17:50 EDT
Besides that it indirectly (rhn_check) spits out bogus error messages
(filed as Bug <A
HREF="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=17933">17933</A>)
it should not run by default since it's by default unconfigured. No need to
have a yet useless daemon running (useless because unconfigured).

Proposal: make RHN configuration smarter to have it activate the rhnsd
daemon after EXPLICIT user confirmation.
Comment 1 Preston Brown 2000-10-04 14:45:47 EDT
we want Red Hat Network to begin working as soon as registration is complete. 
Because we cannot change the registration program (it is fairly senseless to
issue an errata for this program), we will continue to rely on the ability of
rhnsd to run even if it is not configured.  It consumes only a few kilobytes of
memory and is very small and secure.  However, per bug 17933, we have made rhnsd
smarter, and it checks for /etc/sysconfig/rhn/systemid before trying to execute
any sub-actions, failing with a syslog message at the DEBUG level if it is not
present, which should be suitable.

Note You need to log in before you can comment on or make changes to this bug.