Bug 1793471 - Missing arm_bf16.h header on aarch64
Summary: Missing arm_bf16.h header on aarch64
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1794271 (view as bug list)
Depends On:
Blocks: GCC10
TreeView+ depends on / blocked
 
Reported: 2020-01-21 12:24 UTC by Remi Collet
Modified: 2020-10-05 08:30 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-22 07:16:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Remi Collet 2020-01-21 12:24:19 UTC
See https://koji.fedoraproject.org/koji/taskinfo?taskID=40815537


/usr/lib/gcc/aarch64-redhat-linux/10/include/arm_neon.h:34612:10: fatal
error: arm_bf16.h: No such file or directory

Comment 1 Jakub Jelinek 2020-01-21 12:52:30 UTC
Indeed, I have added the new i?86/x86_64 intrinsics but missed the arm/aarch64 ones, so we'll need
following.
diff --git a/gcc.spec b/gcc.spec
index 59a6d95..b531b7c 100644
--- a/gcc.spec
+++ b/gcc.spec
@@ -2145,11 +2145,14 @@ end
 %{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_major}/include/arm_acle.h
 %{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_major}/include/arm_cmse.h
 %{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_major}/include/arm_fp16.h
+%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_major}/include/arm_bf16.h
 %endif
 %ifarch aarch64
 %{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_major}/include/arm_neon.h
 %{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_major}/include/arm_acle.h
 %{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_major}/include/arm_fp16.h
+%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_major}/include/arm_bf16.h
+%{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_major}/include/arm_sve.h
 %endif
 %ifarch sparc sparcv9 sparc64
 %{_prefix}/lib/gcc/%{gcc_target_platform}/%{gcc_major}/include/visintrin.h

Comment 2 Jakub Jelinek 2020-01-21 15:47:56 UTC
gcc-10.0.1-0.4.fc32 with this is building, but it will take at least 10 more hours to build on some slow architectures.

Comment 3 Remi Collet 2020-01-22 07:16:50 UTC
I confirm fix is ok: php 7.4.2 successfuly built with gcc 10.0.1-0.4.fc32

Thanks

Comment 4 Jakub Jelinek 2020-01-23 07:43:24 UTC
*** Bug 1794271 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.