Bug 1793492 - cli: duplicate defns of cli_default_conn_timeout and cli_ten_minutes_timeout
Summary: cli: duplicate defns of cli_default_conn_timeout and cli_ten_minutes_timeout
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: 7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-21 13:35 UTC by Kaleb KEITHLEY
Modified: 2020-01-22 18:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-22 18:32:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 24051 0 None Merged cli: duplicate defns of cli_default_conn_timeout and cli_ten_minutes_timeout 2020-01-22 18:32:19 UTC

Description Kaleb KEITHLEY 2020-01-21 13:35:57 UTC
Description of problem:

fedora-32 will ship with gcc-10.

Compiling with gcc-10-20191219 snapshot reveals dupe defns of
cli_default_conn_timeout and cli_ten_minutes_timeout in
.../cli/src/cli.[ch] due to missing extern decl.

gcc-10 no longer puts globals in the "common" section.

See https://review.gluster.org/#/c/glusterfs/+/23956/


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2020-01-22 18:32:20 UTC
REVIEW: https://review.gluster.org/24051 (cli: duplicate defns of cli_default_conn_timeout and cli_ten_minutes_timeout) merged (#1) on release-7 by Kaleb KEITHLEY


Note You need to log in before you can comment on or make changes to this bug.