Bug 1793495 - pcp-5.0.2-1.fc32 FTBFS: pcp-5.0.2/src/libpcp_web/src/../../../src/include/pcp/sds.h:37: multiple definition of `SDS_NOINIT'; sds.o:/builddir/build/BUILD/pcp-5.0.2/src/libpcp_web/src/../../../src/include/pcp/sds.h:37: first defined here
Summary: pcp-5.0.2-1.fc32 FTBFS: pcp-5.0.2/src/libpcp_web/src/../../../src/include/pcp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pcp
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nathan Scott
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 1793519 (view as bug list)
Depends On:
Blocks: F32FTBFS PYTHON39 GCC10
TreeView+ depends on / blocked
 
Reported: 2020-01-21 13:38 UTC by Petr Pisar
Modified: 2020-03-16 20:29 UTC (History)
5 users (show)

Fixed In Version: pcp-5.0.3 pcp-5.0.3-2.fc31 pcp-5.0.3-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-11 22:45:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Pisar 2020-01-21 13:38:35 UTC
pcp-5.0.2-1.fc32 fails to build in F32:

cc -Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wall -L./src/libpcp/src -L./src/libpcp_web/src -L./src/libpcp_pmda/src  -Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wall -L../src/libpcp/src -L../src/libpcp_web/src -L../src/libpcp_pmda/src  -Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wall -L../../src/libpcp/src -L../../src/libpcp_web/src -L../../src/libpcp_pmda/src  -Wl,-z,relro -Wl,--as-needed  -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wall -L../../../src/libpcp/src -L../../../src/libpcp_web/src -L../../../src/libpcp_pmda/src  -shared -Wl,-soname,libpcp_web.so.1 -Wl,--version-script=exports -o libpcp_web.so.1  jsmn.o http_client.o http_parser.o sds.o siphash.o query.o schema.o load.o crc16.o sha1.o util.o slots.o redis.o net.o dict.o ini.o maps.o batons.o encoding.o json_helpers.o config.o libuv.o discover.o webgroup.o sslio.o     query_parser.tab.o -lssl -lcrypto  -luv -lrt -lpthread -ldl  -lpcp_pmda -lpcp -lm -luv -lrt -lpthread -ldl  -lssl -lcrypto   -ldl 
/usr/bin/ld: query.o: in function `$d':
/builddir/build/BUILD/pcp-5.0.2/src/libpcp_web/src/../../../src/include/pcp/sds.h:37: multiple definition of `SDS_NOINIT'; sds.o:/builddir/build/BUILD/pcp-5.0.2/src/libpcp_web/src/../../../src/include/pcp/sds.h:37: first defined here
[...]
collect2: error: ld returned 1 exit status
make[3]: *** [../../../src/include/buildrules:88: libpcp_web.so.1] Error 1
make[2]: *** [GNUmakefile:22: default] Error 2

A difference between passing and failing build root is at <https://koschei.fedoraproject.org/build/7743352>. This is probably triggered by upgrading gcc from 9.2.1-1.fc32.3 to 10.0.1-0.3.fc32.

Comment 1 Nathan Scott 2020-01-21 21:54:41 UTC
Thanks Petr, this is fixed upstream and will arrive in the next minor PCP update - schedule here:
https://github.com/performancecopilot/pcp/projects/1

so, end of Feb - if a patched 5.0.2 build fix is needed more urgently, please let me know.

cheers.

Comment 2 Nathan Scott 2020-01-21 22:11:26 UTC
*** Bug 1793519 has been marked as a duplicate of this bug. ***

Comment 3 Ben Cotton 2020-02-11 17:24:34 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 4 Fedora Update System 2020-02-27 11:26:01 UTC
FEDORA-2020-1948419b2e has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-1948419b2e

Comment 5 Fedora Update System 2020-02-27 18:38:14 UTC
pcp-5.0.3-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-1948419b2e

Comment 6 Fedora Update System 2020-02-28 01:27:27 UTC
pcp-5.0.3-1.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7ac95d60db

Comment 7 Fedora Update System 2020-03-02 05:27:54 UTC
FEDORA-2020-a4236a5dcf has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a4236a5dcf

Comment 8 Fedora Update System 2020-03-02 19:56:53 UTC
pcp-5.0.3-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a4236a5dcf

Comment 9 Fedora Update System 2020-03-11 22:45:54 UTC
pcp-5.0.3-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2020-03-16 20:16:54 UTC
pcp-5.0.3-1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2020-03-16 20:29:37 UTC
pcp-5.0.3-1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.