Bug 1793496 - trellis fails to build with Python 3.9: Fails to detect Boost
Summary: trellis fails to build with Python 3.9: Fails to detect Boost
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: trellis
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gabriel Somlo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON39
TreeView+ depends on / blocked
 
Reported: 2020-01-21 13:38 UTC by Miro Hrončok
Modified: 2020-04-08 11:48 UTC (History)
5 users (show)

Fixed In Version: trellis-1.0-0.6.20200127git30ee6f2.fc30 trellis-1.0-0.6.20200127git30ee6f2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-08 01:38:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-01-21 13:38:36 UTC
trellis fails to build with Python 3.9.0a2.

Call Stack (most recent call first):
  CMakeLists.txt:43 (find_package)
-- Could NOT find Boost (missing: python-py3) (found version "1.69.0")
-- Could NOT find Boost (missing: python3) (found version "1.69.0")
-- Could NOT find Boost (missing: python36) (found version "1.69.0")
-- Could NOT find Boost (missing: python37) (found version "1.69.0")
-- Could NOT find Boost (missing: python38) (found version "1.69.0")
CMake Warning at /usr/share/cmake/Modules/FindBoost.cmake:2020 (message):
  No header defined for python-3.9; skipping header check (note: header-only
  libraries have no designated component)
Call Stack (most recent call first):
  CMakeLists.txt:64 (find_package)
-- Could NOT find Boost (missing: python-3.9) (found version "1.69.0")
CMake Error at CMakeLists.txt:71 (message):
  No version of Boost::Python 3.x could be found.

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01170183-trellis/

For all our attempts to build trellis with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/trellis/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Fedora Update System 2020-01-29 19:01:34 UTC
FEDORA-2020-a987b290c3 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a987b290c3

Comment 2 Fedora Update System 2020-01-31 01:30:00 UTC
trellis-1.0-0.6.20200127git30ee6f2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-3f7ad94630

Comment 3 Fedora Update System 2020-01-31 02:25:57 UTC
trellis-1.0-0.6.20200127git30ee6f2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a987b290c3

Comment 4 Fedora Update System 2020-02-08 01:38:16 UTC
trellis-1.0-0.6.20200127git30ee6f2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2020-02-08 02:01:28 UTC
trellis-1.0-0.6.20200127git30ee6f2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Deepika Upadhyay 2020-04-07 11:15:11 UTC
Still seeing it in Fedora 31 

CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:146 (message):
  Could NOT find Boost (missing: python38) (found suitable version "1.69.0",
  minimum required is "1.67")
Call Stack (most recent call first):

Comment 7 Gabriel Somlo 2020-04-08 11:48:29 UTC
(In reply to Deepika Upadhyay from comment #6)
> Still seeing it in Fedora 31 
> 
> CMake Error at
> /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:146 (message):
>   Could NOT find Boost (missing: python38) (found suitable version "1.69.0",
>   minimum required is "1.67")
> Call Stack (most recent call first):

Sorry, I can't reproduce this. I grabbed the current package in F31 updates:

   wget https://dl.fedoraproject.org/pub/fedora/linux/updates/31/Everything/SRPMS/Packages/t/trellis-1.0-0.6.20200127git30ee6f2.fc31.src.rpm

and successfully built it in mock:

   mock -r fedora-31-x86_64 trellis-1.0-0.6.20200127git30ee6f2.fc31.src.rpm

without issues. It must have worked even on Fedora's own f31 builders at some point, since I obviously succeeded in building and pushing binaries corresponding to the above-mentioned SRPM for F31 updates already...

Please feel free to follow up with more details if you continue having problems.


Note You need to log in before you can comment on or make changes to this bug.