Bug 1793535 - OCP 4.3 - Node Feature Discovery (NFD) nfd-operator fails to deploy from OperatorHub on OpenShift Console UPI stage
Summary: OCP 4.3 - Node Feature Discovery (NFD) nfd-operator fails to deploy from Oper...
Keywords:
Status: CLOSED DUPLICATE of bug 1789560
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node Feature Discovery Operator
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.0
Assignee: Zvonko Kosic
QA Contact: Walid A.
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-21 14:22 UTC by Walid A.
Modified: 2020-01-22 02:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-21 16:03:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Walid A. 2020-01-21 14:22:57 UTC
Description of problem:
Node Feature Discovery (NFD) nfd-operator fails to deploy from OperatorHub on OpenShift Console.
This is on OCP 4.3rc3 UPI install openstack stage environment

Error displayed on console:  Failed: install failed: Timeout: deployment nfd-operator not ready before timeout: deployment "nfd-operator" exceeded its progress deadline

nfd-operator logs show:

$ oc get pods -n test-nfd 
NAME                            READY   STATUS             RESTARTS   AGE
nfd-operator-6db7bd4d5c-x2xd4   0/1     CrashLoopBackOff   13         44m

$ oc logs -n test-nfd nfd-operator-6db7bd4d5c-x2xd4
{"level":"info","ts":1579614241.503777,"logger":"cmd","msg":"Go Version: go1.12.12"}
{"level":"info","ts":1579614241.5040224,"logger":"cmd","msg":"Go OS/Arch: linux/amd64"}
{"level":"info","ts":1579614241.5040557,"logger":"cmd","msg":"Version of operator-sdk: v0.4.0+git"}
{"level":"info","ts":1579614241.5050883,"logger":"leader","msg":"Trying to become the leader."}
{"level":"info","ts":1579614241.6758485,"logger":"leader","msg":"Found existing lock with my name. I was likely restarted."}
{"level":"info","ts":1579614241.675885,"logger":"leader","msg":"Continuing as the leader."}
{"level":"info","ts":1579614241.8064446,"logger":"cmd","msg":"Registering Components."}
{"level":"info","ts":1579614241.806859,"logger":"kubebuilder.controller","msg":"Starting EventSource","controller":"nodefeaturediscovery-controller","source":"kind source: /, Kind="}
{"level":"info","ts":1579614241.807171,"logger":"kubebuilder.controller","msg":"Starting EventSource","controller":"nodefeaturediscovery-controller","source":"kind source: /, Kind="}
{"level":"info","ts":1579614241.8072743,"logger":"kubebuilder.controller","msg":"Starting EventSource","controller":"nodefeaturediscovery-controller","source":"kind source: /, Kind="}
{"level":"info","ts":1579614241.807353,"logger":"kubebuilder.controller","msg":"Starting EventSource","controller":"nodefeaturediscovery-controller","source":"kind source: /, Kind="}
{"level":"info","ts":1579614241.807523,"logger":"kubebuilder.controller","msg":"Starting EventSource","controller":"nodefeaturediscovery-controller","source":"kind source: /, Kind="}
{"level":"error","ts":1579614241.8075442,"logger":"cmd","msg":"","error":"no kind is registered for the type v1.SecurityContextConstraints in scheme \"k8s.io/client-go/kubernetes/scheme/register.go:60\"","stacktrace":"github.com/openshift/cluster-nfd-operator/vendor/github.com/go-logr/zapr.(*zapLogger).Error\n\t/go/src/github.com/openshift/cluster-nfd-operator/vendor/github.com/go-logr/zapr/zapr.go:128\nmain.main\n\t/go/src/github.com/openshift/cluster-nfd-operator/cmd/manager/main.go:92\nruntime.main\n\t/opt/rh/go-toolset-1.12/root/usr/lib/go-toolset-1.12-golang/src/runtime/proc.go:200"}

nfd operator image it is trying to deploy:
registry.stage.redhat.io/openshift4/ose-cluster-nfd-operator@sha256:c222531c415f87bb297cb570567bc0e8352e243ac92bf121a83b1b4a759d2e48


Version-Release number of selected component (if applicable):
$ oc version
Client Version: 4.3.0-rc.2
Server Version: 4.3.0-rc.3
Kubernetes Version: v1.16.2
$ oc get clusterversion
NAME      VERSION      AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.3.0-rc.3   True        False         6h      Cluster version is 4.3.0-rc.3

How reproducible:
Once 

Steps to Reproduce:
1. UPI install of OCP 4.3 rc3 on openstack, 2 worker nodes and 3 masters
2. From OpenShift console logged in as kubeadmin, with kubeadmin password from install
3. Create namespace called test-nfd
4. Operators -> OperatorHub, search for NFD operator, click install
5. Select 4.3 Update channel, and select test-nfd namespace to install

Actual results:
NFD operator fails to install


Expected results:
NFD operator to install successfully

Additional info:
The same error is also seen when trying to deploy nfd operator from github and CLI (see:  https://bugzilla.redhat.com/show_bug.cgi?id=1789560)

Comment 1 Stephen Cuppett 2020-01-21 15:17:43 UTC
Setting target release to the active development version (4.4). Fixes, if any, where requested/required for previous versions will result in clones targeting those z-stream releases.

Comment 2 Stephen Cuppett 2020-01-21 16:03:32 UTC

*** This bug has been marked as a duplicate of bug 1789560 ***


Note You need to log in before you can comment on or make changes to this bug.