Bug 1793679 - [RFE] Modify behavior of qpid-stat for 6.6+
Summary: [RFE] Modify behavior of qpid-stat for 6.6+
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Qpid
Version: 6.6.0
Hardware: x86_64
OS: Linux
unspecified
low vote
Target Milestone: Unspecified
Assignee: Mike Cressman
QA Contact: Radovan Drazny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-21 19:43 UTC by patalber
Modified: 2020-02-13 15:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-13 15:31:20 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description patalber 2020-01-21 19:43:46 UTC
Description of problem:
In pre-6.6, the certificate /etc/pki/katello/qpid_client_striped.crt existed. In 6.6, this was removed, so the command no longer functions properly. This may be a part of sosreport and should be looked into soon.

Version-Release number of selected component (if applicable):
Satellite 6.6

How reproducible:
100%

Steps to Reproduce:
1. Run 'qpid-stat --ssl-certificate=/etc/pki/katello/qpid_client_striped.crt'
2. Watch it fail.
3.

Actual results:
Failure (since certificate no longer exists)

Expected results:
normal 'qpid-stat'-type output

Additional info:
Use “qpid-stat --ssl-certificate=/etc/pki/pulp/qpid/client.crt -b amqps://localhost:5671 -q” going forward. As of 6.6 /etc/pki/katello/qpid_client_striped.crt no longer exists

Comment 3 Eric Helms 2020-02-13 15:31:20 UTC
Both sosreport and foreman-debug handle this situation already, therefore I am closing as notabug.


Note You need to log in before you can comment on or make changes to this bug.