Bug 179374 - crashes during startup
crashes during startup
Status: CLOSED DUPLICATE of bug 176992
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-30 13:03 EST by Dave Jones
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 16:17:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-01-30 13:03:58 EST
during bootup, I noticed this.
userhelper[2773] general protection rip:40375d rsp:7fffff9cf800 error:0

and found a core file which had the following backtrace..

#0  0x000000000040375d in converse_pipe (num_msg=0, msg=0x0, resp=0x0,
appdata_ptr=Variable "appdata_ptr" is not available.
)
    at userhelper.c:476
476             if ((get_pam_string_item(data->pamh, PAM_USER, &user) !=
PAM_SUCCESS) ||
(gdb) bt
#0  0x000000000040375d in converse_pipe (num_msg=0, msg=0x0, resp=0x0,
appdata_ptr=Variable "appdata_ptr" is not available.
)
    at userhelper.c:476
#1  0x0000000000403dd7 in pipe_conv_exec_start (conv=Variable "conv" is not
available.
) at userhelper.c:1011
#2  0x0000000000404f28 in wrap (user=0x50b370 "root", program=0x7fffff9d095f
"reboot",
    conv=0x7fffff9cfb50, text_conv=0x7fffff9cfb40, prompt=Variable "prompt" is
not available.
) at userhelper.c:2247
#3  0x000000000040530b in main (argc=3, argv=0x7fffff9cfc98) at userhelper.c:2532
#4  0x0000003ea1f1cde4 in __libc_start_main () from /lib64/libc.so.6
#5  0x0000000000402e39 in _start ()
#6  0x00007fffff9cfc88 in ?? ()
#7  0x0000000000000000 in ?? ()
Comment 1 Jindrich Novy 2006-01-31 09:38:46 EST
Ugh. During boot-up?

Something looks seriously fubared when some app is called via userhelper in the
boot time... Could you install the userelper from the bug 176992 an reboot
again? Also a name of the app called via userhelper would help me as I can then
check what PAM modules are used for "authentication" what might cause the crash.
Comment 2 Dave Jones 2006-02-01 16:17:08 EST
I think it wasn't actually during boot, it just looked that way in the logs, due
to syslog being strange and interspersing the boot messages with things that
happened later.

This looks like a dupe of 176992.


*** This bug has been marked as a duplicate of 176992 ***

Note You need to log in before you can comment on or make changes to this bug.