Bug 179381 - RHEL-4 update to FC5t2 leaves behind incorrect kernels
RHEL-4 update to FC5t2 leaves behind incorrect kernels
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-01-30 14:13 EST by Stephen Tweedie
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 15:26:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2006-01-30 14:13:40 EST
Description of problem:

I updated a RHEL-4WS x86_64 SMP box to FC5 test2 using the boot.iso and NFS.  
The default kernel prior to the update was kernel-smp-2.6.9-22.0.2.EL.  After
the update, kernel-2.6.15-1.1826.2.10_FC5 was installed, but was not booted (it
defaulted to the old 2.6.9-22.0.2.EL SMP kernel); and the old kernel- and
kernel-smp 2.6.9-22, -22.0.1 and -22.0.2.EL were left behind.

This had two consequences:
X would not start, as hotplug was totally broken by the booting of the old
kernel; and

yum update would not work, as the old 2.6.9 kernels conflicted with new
kudzu/udev/initscripts etc. packages.

Version-Release number of selected component (if applicable):
All default FC5t2 packages.

How reproducible:
Have not tried.

Steps to Reproduce:
1. Install RHEL-4U2
2. Enable update to FC5t2 by manually installing fedora-release rpm
3. Run the FC5t2 upgrade
  
Actual results:
Old RHEL-4 kernels left behind as default kernels.

Expected results:
Old kernels should be removed and the new kernel should be the default one to
boot from.

Additional info:
Comment 1 Jeremy Katz 2006-01-30 14:15:54 EST
We probably want to just have the kernel package doing the right thing here. 
That would need kernel obsoleting kernel-smp < something reasonable for x86_64.
 Then the tricky part is switching the /etc/sysconfig/kernel stuff so that the
right kernel gets made default.
Comment 2 Stephen Tweedie 2006-01-30 14:47:08 EST
I suspect grubby needs to be involved too.  As I understand things right now, we
only ever update the default boot line in grub if the new kernel is replacing an
existing default one of the same variant.  Replacing a kernel-smp with a kernel
package may not trigger that.
Comment 3 Dave Jones 2006-01-30 22:24:22 EST
The kernel spec has had..

%ifarch x86_64
Obsoletes: kernel-smp
%endif

Since ~ November.
Comment 4 Paul Nasrat 2006-01-30 22:33:49 EST
The kernel is processed as 'i' with in the transaction install only which does
not do any erases (including obsoletes).
Comment 5 Stephen Tweedie 2006-01-30 23:00:33 EST
Even if it did do obsoletes, that wouldn't fix up the grub config entry.
Comment 6 Jeremy Katz 2006-01-30 23:07:28 EST
Hmm, we should definitely be overriding the installonlypkgs as we don't ever
want that behavior from anaconda.  Problems like this are just too painful. 
Paul -- want to fix this up?

Dave -- we probably still need to do something for munging /etc/sysconfig/kernel
so that the right thing gets set as default by grubby.  We basically just need
to do:
  sed -e -i 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/'
/etc/sysconfig/kernel
Kind of gross though :-/
Comment 7 Paul Nasrat 2006-01-31 12:41:01 EST
I've fixed anaconda up to override installonlypkgs
Comment 8 Dave Jones 2006-02-03 15:00:28 EST
kernel now has..
if [ `uname -i` == "x86_64" ]; then
  sed -e -i 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/'
/etc/sysconfig/kernel
fi

as the first thing in its %post 
Comment 9 Rahul Sundaram 2006-02-20 05:41:55 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 10 Jeremy Katz 2006-02-20 15:26:46 EST
This should be handled properly in test3

Note You need to log in before you can comment on or make changes to this bug.