Bug 1793870 - Broken dependency on xmlrpc package from eclipse-pydev
Summary: Broken dependency on xmlrpc package from eclipse-pydev
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-pydev
Version: 32
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-22 06:46 UTC by George R. Goffe
Modified: 2020-04-06 00:16 UTC (History)
22 users (show)

Fixed In Version: eclipse-pydev-7.5.0-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-06 00:16:43 UTC
Type: Bug


Attachments (Terms of Use)
gzip'd tar file of installer logs from /tmp (31.85 KB, application/gzip)
2020-03-04 19:38 UTC, George R. Goffe
no flags Details

Description George R. Goffe 2020-01-22 06:46:33 UTC
Description of problem: Attempting to install a new system in a VM. After configuring this system I attempted to select all the pkgs under the kde plasma workspaces. Apparently the eclipse package had some problems. Instead of offering the option to back out this selection, I received a popup with ONLY ONE OPTION... To terminate the installation.


Version-Release number of selected component (if applicable):
Fedora-Everything-netinst-x86_64-Rawhide-20200117.n.0.iso

How reproducible:
always

Steps to Reproduce:
1.see above
2.
3.

Actual results:
see above

Expected results:
in the event of errors, the user should be offered the option to remove any problem packages AND CONTINUE THE INSTALLATION.

Additional info:

Comment 1 Ben Cotton 2020-02-11 17:30:02 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 2 George R. Goffe 2020-02-13 05:29:11 UTC
Ben,

I just tried to install FC32 x86_64 (Rawhide) and selected the eclipse package group as mentioned above. The problem STILL EXISTS. ALL the packages who fail for whatever reason SHOULD give the user the option to make changes to the package selection(s) AND try again to install. Python Science had a problem AND did this right. Eclipse STILL hasn't changed it's behavior AND ABANDONS the installation instead of allowing the user to remove that package group from the selected packages.

I'm wondering how many other package groups have this same problem.

Regards,

George...

Comment 3 Vendula Poncova 2020-03-04 14:05:19 UTC
Hi, I am not able to reproduce the issue. Please, attach all logs (including syslog) from the installation. You can find them during the installation in /tmp.

Comment 4 George R. Goffe 2020-03-04 18:37:21 UTC
Vendula,

Thanks for responding.

I have worked around the problem by installing what I wanted AFTER the install, the problem is STILL aggravating. I haven't figured out just how to get the log files from the VM to the "real" world. Any ideas? How about "ctrl-f3;start sshd;scp from /tmp"?

I selected the KDE Plasma Workspaces which gave me another menu of additional packages to request. Initially I selected all of them but the install choked on the "Fedora Eclipse". I got a message about "there was a problem" but the popup only offered "Terminate the install". That's what I'm reporting.

Regards,

George...

Comment 5 George R. Goffe 2020-03-04 19:38:12 UTC
Created attachment 1667575 [details]
gzip'd tar file of installer logs from /tmp

Vendula,

I just tried an install with the "latest" .iso for FC33...

This "current" problem has disappeared but left some others in it's wake.

There is a notification now that errors have occurred BUT, there is NO way to determine which selections caused the problems. What am I to do now? Guess and remove? I don't see anyway to remove specific packages from the "groups" I selected.

Other problems are:
1) when partitioning I used an existing system disk which appeared in the "Unknown Linux". You have to poke this link(?) EVERY time you want to refer to partitions in it. This IS NOT VERY Convenient.
2) my idea of starting sshd from a different tty worked great but I had to copy sshd_config.anaconda to sshd_config since "systemctl start sshd" wanted 'sshd_config'. I have sshd disabled on my host due to numerous attempts by hackers to gain access to my system. ARGH! A POX on them!

So, here is a tar file of the logs that I scp'd from the installer on the VM to my host system.

Thanks for your help with this.

George...

Comment 6 George R. Goffe 2020-03-06 18:15:00 UTC
Vendula,

Is there any progress in the resolution of this bug report?

I would like to suggest that "--skip-broken" be added to the dnf commands invoked by the installation process. 

Regards,

George...

Comment 7 Vendula Poncova 2020-03-09 12:14:17 UTC
(In reply to George R. Goffe from comment #5)
> Created attachment 1667575 [details]
> gzip'd tar file of installer logs from /tmp
> 
> Vendula,
> 
> I just tried an install with the "latest" .iso for FC33...
> 
> This "current" problem has disappeared but left some others in it's wake.
> 
> There is a notification now that errors have occurred BUT, there is NO way
> to determine which selections caused the problems. What am I to do now?
> Guess and remove? I don't see anyway to remove specific packages from the
> "groups" I selected.

These suggestions would have to be provided by DNF, Anaconda just shows their output. Reassigning to DNF.

> Other problems are:
> 1) when partitioning I used an existing system disk which appeared in the
> "Unknown Linux". You have to poke this link(?) EVERY time you want to refer
> to partitions in it. This IS NOT VERY Convenient.

Please, report a new bug with this issue.

> 2) my idea of starting sshd from a different tty worked great but I had to
> copy sshd_config.anaconda to sshd_config since "systemctl start sshd" wanted
> 'sshd_config'. I have sshd disabled on my host due to numerous attempts by
> hackers to gain access to my system. ARGH! A POX on them!

You can run the installation with the boot option inst.sshd to start up sshd. See: https://anaconda-installer.readthedocs.io/en/latest/boot-options.html#inst-sshd

Comment 8 Vendula Poncova 2020-03-09 12:17:43 UTC
(In reply to George R. Goffe from comment #6)
> Vendula,
> 
> Is there any progress in the resolution of this bug report?
> 
> I would like to suggest that "--skip-broken" be added to the dnf commands
> invoked by the installation process. 
> 
> Regards,
> 
> George...

Anaconda supports that for kickstart installations. See the --ignorebroken option of the %packages section (https://pykickstart.readthedocs.io/en/latest/kickstart-docs.html#chapter-9-package-selection).

Comment 9 Jaroslav Mracek 2020-03-18 16:46:07 UTC
In packaging log there is everything what is required for debugging.

Example:
Problem 1: conflicting requests
  - nothing provides xmlrpc-client needed by eclipse-pydev-1:7.1.0-2.fc31.x86_64
  - nothing provides xmlrpc-common needed by eclipse-pydev-1:7.1.0-2.fc31.x86_64
  - nothing provides xmlrpc-server needed by eclipse-pydev-1:7.1.0-2.fc31.x86_64

When you search log for eclipse-pydev you can see that it is part of group 'eclipse' (11:14:59,641 DBG dnf: Adding packages from group 'eclipse':). 

I suggest that the issue is not in DNF, and also not in Anaconda, but in packaging (missing dependency). I will try to reassign the component to something more relevant.

Comment 10 George R. Goffe 2020-03-18 19:01:12 UTC
Jaroslav,

Thank you for responding to this bug report, IT IS APPRECIATED!

Maybe there is already an answer to what I'm asking below. I would appreciate any pointers/hints/tips.

Can you help me to do more of this kind of research myself please? It would help "us" all if I could narrow down to a specific package causing trouble.

I am not a dnf/yum/rpm expert by ANY stretch of the imagination. What dnf commands should be issued by me? Perhaps a brief "flow chart"? Are there other commands? I know this is a big question but it would help me and maybe most of the other people writing bug reports. Occasionally I run across a package that is NOT in bugzilla. Who should I notify about that?

Something short and sweet would be GREATLY appreciated by me for sure. I WANT to write better bug reports.

What do you think?

Best regards and, again, thanks for your help.

George...

Comment 11 Mat Booth 2020-04-01 17:37:42 UTC
Thanks for referring this to the pydev package, there was indeed a broken dep on xmlrpc. Renaming the bug appropriately.

Comment 12 Fedora Update System 2020-04-01 20:39:45 UTC
FEDORA-2020-1d0635bd71 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-1d0635bd71

Comment 13 Fedora Update System 2020-04-02 02:17:06 UTC
FEDORA-2020-1d0635bd71 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-1d0635bd71`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-1d0635bd71

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2020-04-06 00:16:43 UTC
FEDORA-2020-1d0635bd71 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.