Bug 1793917 - perl-Test-mysqld-1.0012-4.fc32 FTBFS: DBI connect('dbname=mysql;mysql_socket=/tmp/B_Fm_kLtjo/tmp/mysql.sock;user=root','',...) failed: Access denied for user 'root'@'localhost' at /builddir/build/BUILD/Test-mysqld-1.0012/blib/lib/Test/mysqld.pm line 143.
Summary: perl-Test-mysqld-1.0012-4.fc32 FTBFS: DBI connect('dbname=mysql;mysql_socket=...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Test-mysqld
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On: 1796106
Blocks: F32FTBFS
TreeView+ depends on / blocked
 
Reported: 2020-01-22 09:25 UTC by Petr Pisar
Modified: 2020-04-09 14:43 UTC (History)
3 users (show)

Fixed In Version: perl-Test-mysqld-1.0012-6.fc33 perl-Test-mysqld-1.0012-6.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-09 14:43:56 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github kazuho p5-test-mysqld issues 32 0 None open Tests fail with mariadb-10.4.11: Access denied for user 'root'@'localhost' at lib/Test/mysqld.pm line 143 2020-04-12 18:15:02 UTC

Description Petr Pisar 2020-01-22 09:25:15 UTC
perl-Test-mysqld-1.0012-4.fc32 fails to build in Fedora 32 because tests fail:

t/00-base.t ............ ok
DBI connect('dbname=mysql;mysql_socket=/tmp/B_Fm_kLtjo/tmp/mysql.sock;user=root','',...) failed: Access denied for user 'root'@'localhost' at /builddir/build/BUILD/Test-mysqld-1.0012/blib/lib/Test/mysqld.pm line 143.
Access denied for user 'root'@'localhost' at /builddir/build/BUILD/Test-mysqld-1.0012/blib/lib/Test/mysqld.pm line 143.
t/01-raii.t ............ 
Dubious, test returned 255 (wstat 65280, 0xff00)
No subtests run 

A difference between passing and failing build root is at <https://koschei.fedoraproject.org/build/7747723>. An upgrade of mariadb-server from 3:10.3.21-3.fc32 to 3:10.4.11-1.fc32 looks suspicious.

Comment 1 Ben Cotton 2020-02-11 17:23:04 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 2 Fedora Release Engineering 2020-02-16 04:34:02 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 3 Fedora Release Engineering 2020-03-01 04:26:05 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 4 Michal Schorm 2020-03-03 11:59:59 UTC
May be related to https://bugzilla.redhat.com/show_bug.cgi?id=1796106 ?
It's a new issue related to MariaDB 10.4, which was introduced in F32.
We are working on a solution, currently in dialogue with the MariaDB upstream.

If you'd spot it may be the same issue, feel free to link that this BZ is block by that BZ.

Comment 5 Fedora Release Engineering 2020-03-08 04:28:13 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 32.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (that's on 2020-03-18).

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-33/f-33-key-tasks.html

Comment 6 Fedora Release Engineering 2020-03-29 04:28:26 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 32.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (that's on 2020-03-18).

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-33/f-33-key-tasks.html

Comment 7 Michal Schorm 2020-03-30 14:49:40 UTC
The blocking BZ was resolved.

The problems are caused by a new default authentication plugin "unix_socket".

> Use '--auth-root-authentication-method=normal' option for the 'mysql_install_db' to revert to the old 10.3 behaviour.
The DB can still be initialized with the old behaviour, maybe that could be a fast fix for your package ?

Comment 8 Petr Pisar 2020-04-01 14:29:37 UTC
I developed a fix that I will apply.

Comment 9 Fedora Update System 2020-04-01 14:47:13 UTC
FEDORA-2020-7159589134 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-7159589134

Comment 10 Fedora Update System 2020-04-02 02:16:57 UTC
FEDORA-2020-7159589134 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-7159589134`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7159589134

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2020-04-09 14:43:56 UTC
FEDORA-2020-7159589134 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.