Bug 1793921 - Baremetal keepalived and haproxy services don't work with IPv6
Summary: Baremetal keepalived and haproxy services don't work with IPv6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Ben Nemec
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On:
Blocks: 1793923
TreeView+ depends on / blocked
 
Reported: 2020-01-22 09:26 UTC by Ben Nemec
Modified: 2020-05-04 11:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Hard-coded ipv4 values in configuration files Consequence: Keepalived and haproxy services deployed in ipv6 environments did not function correctly. Fix: Updated configurations to work with either ipv4 or ipv6. Result: Keepalived and haproxy function as intended on ipv6.
Clone Of:
: 1793923 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:25:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:26:26 UTC

Description Ben Nemec 2020-01-22 09:26:02 UTC
Description of problem: The configuration templates for keepalived and haproxy do not support IPv6-based deployments. There are hard-coded values that do not work correctly with v6 addresses. We need to change these values to ones that will respect both v4 and v6 addresses.

Comment 2 Victor Voronkov 2020-03-12 18:20:35 UTC
Verified on 4.4.0-0.ci-2020-03-11-095511

haproxy.conf:
frontend  main
  bind :::7443 v4v6

keepalived.conf contains only localhost which is resolved to matching protocol

Comment 4 errata-xmlrpc 2020-05-04 11:25:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.