Bug 1793955 - /tests/basic/distribute/rebal-all-nodes-migrate.t is failing in CI
Summary: /tests/basic/distribute/rebal-all-nodes-migrate.t is failing in CI
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-22 10:56 UTC by yati padia
Modified: 2020-01-29 18:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-29 18:02:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description yati padia 2020-01-22 10:56:39 UTC
Description of problem:
The following test case "./tests/basic/distribute/rebal-all-nodes-migrate.t" is failing repeatedly without any error in the patch. It seems it is timing out.

Here is the output of console:

Running tests in file ./tests/basic/distribute/rebal-all-nodes-migrate.t
12:26:48 Logs preserved in tarball rebal-all-nodes-migrate-iteration-1.tar
12:26:48 ./tests/basic/distribute/rebal-all-nodes-migrate.t timed out after 200 seconds
12:26:48 ./tests/basic/distribute/rebal-all-nodes-migrate.t: bad status 124


Actual results:
./tests/basic/distribute/rebal-all-nodes-migrate.t fails with time out of 200 seconds

Expected results:
Centos Regression should pass.

Comment 1 Deepshikha khandelwal 2020-01-28 12:28:36 UTC
https://review.gluster.org/c/glusterfs/+/24025
https://review.gluster.org/c/glusterfs/+/23746
https://review.gluster.org/c/glusterfs/+/23857
https://review.gluster.org/c/glusterfs/+/23715
https://review.gluster.org/c/glusterfs/+/23726
https://review.gluster.org/c/glusterfs/+/23748

All of these patches deal with the similar change and I suspect the change is failing the regression run. 

I tried running this test on one of the builder and it seems to be working fine.

Comment 2 yati padia 2020-01-28 14:10:17 UTC
I don't think that the changes are causing regression failure. The test is successful on my local machine too. And also, the change includes formating the log pattern only.


Note You need to log in before you can comment on or make changes to this bug.