Bug 1793962 - The default template cannot be used in vm wizard
Summary: The default template cannot be used in vm wizard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Filip Krepinsky
QA Contact: Nelly Credi
URL:
Whiteboard:
: 1776064 (view as bug list)
Depends On: 1776064
Blocks: 1808304
TreeView+ depends on / blocked
 
Reported: 2020-01-22 11:24 UTC by Tomas Jelinek
Modified: 2020-07-13 17:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The default YAML VM template was not created with all values required by VM wizard Fix: Default YAML VM template is now dynamically created with all required values from common-templates
Clone Of: 1776064
: 1808304 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:13:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4378 None closed Bug 1793962: make default template compatible with the VM Wizard 2020-06-29 09:10:28 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:13:43 UTC

Description Tomas Jelinek 2020-01-22 11:24:52 UTC
+++ This bug was initially created as a clone of Bug #1776064 +++

Description of problem:
Create a default template via "VM Templates -> "Create from yaml", and try to use it in vm wizard. It says "Could not select Provision Source. No bootable device found.". On the template's network and disk tab, the nic and rootdisk are missing.

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-21-122827

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
The template create from "Create from yaml" can be used in vm wizard.

Additional info:

--- Additional comment from Tomas Jelinek on 2019-12-05 14:35:22 UTC ---

lowering the priority since it is not a blocker for the whole openshift, even though we will get it in 4.3 on time. It just will not be considered a blocker.

--- Additional comment from Tomas Jelinek on 2020-01-22 11:24:13 UTC ---

we agreed some time ago that this should go to z-stream. Now I can move it there, so targeting and cloning.

Comment 1 Filip Krepinsky 2020-02-26 11:22:25 UTC
*** Bug 1776064 has been marked as a duplicate of this bug. ***

Comment 4 Guohua Ouyang 2020-03-31 06:52:08 UTC
verified on 4.5.0-0.nightly-2020-03-29-224016.

Comment 6 errata-xmlrpc 2020-07-13 17:13:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.