Bug 1793998 - python-neurodsp fails to build in Fedora rawhide
Summary: python-neurodsp fails to build in Fedora rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-neurodsp
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aniket Pradhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FTBFS PYTHON39
TreeView+ depends on / blocked
 
Reported: 2020-01-22 13:24 UTC by Miro Hrončok
Modified: 2020-02-17 02:08 UTC (History)
5 users (show)

Fixed In Version: python-neurodsp-2.0.0-3.fc30 python-neurodsp-2.0.0-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-16 15:22:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-01-22 13:24:48 UTC
python-neurodsp fails to build with Python 3.9.0a2.

E           TypeError: object of type <class 'float'> cannot be safely interpreted as an integer.

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01172653-python-neurodsp/

For all our attempts to build python-neurodsp with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/python-neurodsp/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2020-01-22 13:25:39 UTC
I think this is related to numpy 1.18 rather than Python 3.9.

I've turned on tracking of this package in https://koschei.fedoraproject.org/package/python-neurodsp?collection=f32 and will rename this bugzilla if it fails there as well.

Comment 2 Aniket Pradhan 2020-01-28 08:58:01 UTC
The issue is with numpy 1.18.

I have reported the issue and a possible fix upstream. Let's wait for them to respond, otherwise, I will submit a patch to with the rpm spec.

Comment 3 Fedora Update System 2020-02-08 10:40:58 UTC
FEDORA-2020-22eb742c1e has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-22eb742c1e

Comment 4 Fedora Update System 2020-02-08 10:41:00 UTC
FEDORA-2020-fe2f490b72 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-fe2f490b72

Comment 5 Fedora Update System 2020-02-09 01:20:58 UTC
python-neurodsp-2.0.0-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-fe2f490b72

Comment 6 Fedora Update System 2020-02-09 01:46:22 UTC
python-neurodsp-2.0.0-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-22eb742c1e

Comment 7 Ben Cotton 2020-02-11 16:35:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 8 Fedora Update System 2020-02-17 01:26:11 UTC
python-neurodsp-2.0.0-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2020-02-17 02:08:27 UTC
python-neurodsp-2.0.0-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.