Bug 179400 - can't sniff incoming traffic on interface that is part of a bond
can't sniff incoming traffic on interface that is part of a bond
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-30 18:58 EST by Damian Menscher
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 10:18:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jwltest-enable-bind-to-slave-intf.patch (921 bytes, patch)
2006-02-03 16:19 EST, John W. Linville
no flags Details | Diff

  None (edit)
Description Damian Menscher 2006-01-30 18:58:31 EST
Description of problem:
I have a system with interfaces eth0 and eth1 bonded together into an interface
named bond0.  If I sniff traffic on bond0, I see all traffic going both in and
out.  But sometimes I want to see exactly which interface is carrying the
traffic (for debugging, usually).  But if I sniff traffic on eth0 (or eth1) I
only see outbound traffic, not inbound traffic.

Version-Release number of selected component (if applicable):
kernel-2.6.9-22.0.1.EL

How reproducible:
All the time

Steps to Reproduce:
1. create a bonded interface
2. sniff traffic on eth0 or eth1 (NOT bond0)
Comment 1 John W. Linville 2006-01-31 17:12:29 EST
What you are observing is an artifact of how bonding is implemented in the 
kernel (i.e. the hack that is bonding). 
 
Incoming frames are marked as arriving on the bond at a very low level in the 
stack, while outgoing frames on the bond are intercepted and remarked for the 
physical interface, then re-injected high enough in the stack to allow them to 
be sniffed. 
 
I agree that sniffing incoming frames on the physical links in the bond would 
be potentially beneficial, I'm not sure how to do it without breaking 
something or implementing a nasty hack.  I'll give it some thought, but I 
can't be optimistic. 
Comment 2 John W. Linville 2006-02-03 16:19:38 EST
Created attachment 124128 [details]
jwltest-enable-bind-to-slave-intf.patch
Comment 3 John W. Linville 2006-02-03 16:20:41 EST
Test kernels w/ the above patch are available here: 
 
   http://people.redhat.com/linville/kernels/rhel4/ 
 
Please give them a try and post the results here...thanks! 
Comment 4 John W. Linville 2006-03-01 10:18:47 EST
Closed due to lack of response.  Please reopen when the requested info becomes 
available...thanks! 

Note You need to log in before you can comment on or make changes to this bug.