Bug 1794029 - [4.2] update deps to get k8s.io/client-go informer fix
Summary: [4.2] update deps to get k8s.io/client-go informer fix
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.z
Assignee: Dan Winship
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On: 1794022
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-22 14:19 UTC by Dan Winship
Modified: 2020-03-10 20:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1794022
Environment:
Last Closed: 2020-02-24 16:52:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift sdn pull 95 None closed Bug 1794029: [4.2] Use k8s.io/client-go fork with informer fix, run update-deps 2020-04-17 13:28:43 UTC
Red Hat Product Errata RHBA-2020:0460 None None None 2020-02-24 16:52:59 UTC

Description Dan Winship 2020-01-22 14:19:46 UTC
+++ This bug was initially created as a clone of Bug #1794022 +++

Update SDN to backport https://github.com/kubernetes/kubernetes/pull/86015 to prevent lost events during cluster startup.

(Not easily QA-able; the failure mode is very sporadic and we previously had a mostly-working workaround for it [which is removed as part of this change])

Comment 2 zhaozhanqi 2020-02-10 09:34:31 UTC
as `Not easily QA-able`. QE just do some regression testing on 4.2.18. and no regression issue happen. 

Move this bug to 'verified'.

Comment 4 errata-xmlrpc 2020-02-24 16:52:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0460


Note You need to log in before you can comment on or make changes to this bug.