Bug 1794046 - Tower provider throws error when using v2 api endpoint
Summary: Tower provider throws error when using v2 api endpoint
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.11.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.11.2
Assignee: Adam Grare
QA Contact: Nandini Chandra
Red Hat CloudForms Documentation
URL:
Whiteboard: testathon
Depends On: 1740860
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-22 14:45 UTC by Satoe Imaishi
Modified: 2020-03-25 04:02 UTC (History)
16 users (show)

Fixed In Version: 5.11.2.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1740860
Environment:
Last Closed: 2020-02-13 16:25:17 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:
simaishi: cfme-5.11.z?


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 4844821 None None None 2020-02-20 00:14:02 UTC

Comment 2 CFME Bot 2020-01-23 15:32:17 UTC
New commit detected on ManageIQ/manageiq-providers-ansible_tower/ivanchuk:

https://github.com/ManageIQ/manageiq-providers-ansible_tower/commit/02568cbf63ae1a81768bbd0061c7da66ae8a1b08
commit 02568cbf63ae1a81768bbd0061c7da66ae8a1b08
Author:     Jason Frey <jfrey@redhat.com>
AuthorDate: Thu Jan 23 10:21:02 2020 -0500
Commit:     Jason Frey <jfrey@redhat.com>
CommitDate: Thu Jan 23 10:21:02 2020 -0500

    Merge pull request #208 from agrare/bump_ansible_tower_client

    Bump ansible_tower_client to v0.20.2

    (cherry picked from commit 0b9e54c7730b723de374c6854bbe141b6a2f1758)

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1794046

 manageiq-providers-ansible_tower.gemspec | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 3 Nandini Chandra 2020-02-03 20:37:01 UTC
Verified in 5.11.2.2

Comment 4 Nandini Chandra 2020-02-04 23:31:42 UTC
The issue is that Tower refresh failed even though credentials were successfully validated. The Tower refresh failed with this message :

 MIQ(ManageIQ::Providers::AnsibleTower::AutomationManager::Refresher#refresh) EMS: [Tower Automation Manager], id: [99000000000005] Unable to perform refresh for the following targets:
- undefined method `vault_password' for #<AnsibleTowerClient::Credential::Inputs:0x000055eea78a7578>  Method:[block (2 levels) in <class:LogProxy>]"

This issue doesn't occur if there is a Vault credential on the Tower setup.

I verified the issue on a 5.11.2.2 appliance managing Tower 3.6


Note You need to log in before you can comment on or make changes to this bug.