Bug 179408 - Smartd fails on startup (default config fails)
Smartd fails on startup (default config fails)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: smartmontools (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-30 19:56 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 12:42:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2006-01-30 19:56:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
Smartd's default config appears to assume disks hda and hdb are installed.
This is incorrect on my machine - I have disks hda and sda. There seems to be an option to scan devices, but it's not enabled in my config file. 

I think the default config file for an init service should work out of the box. 
The current config fails, which is a bug. It also doesn't report why it failed, which is another bug. I have to force the daemon to run in the foreground to find out why it failed.




Version-Release number of selected component (if applicable):
smartmontools-5.33-4

How reproducible:
Always

Steps to Reproduce:
1. Install one PATA and one SATA disk.
2. Run smartd on startup
  

Additional info:
Comment 1 Tomas Mraz 2006-01-31 02:35:03 EST
Is it possible that you had hda and hdb disks on your machine when your system
was first booted after installation?

In the first start of the smartd there is no smartd.conf file and it's generated
by smartd-conf.py script. You can try to remove smartd.conf and restart smartd a
correct smartd.conf should be generated.
Comment 2 Ivan Gyurdiev 2006-01-31 02:42:03 EST
Yes, it is possible - I did have hda/hdb, and that's no longer true... 
I think Linux should be able to handle changes in the underlying hardware.
Comment 3 Tomas Mraz 2006-03-22 12:42:44 EST
The current smartd configuration in rawhide should make smartd not fail if some
drive is no longer connected. So it's now partially fixed. To make smartd handle
all changes in underlying hardware would require non-trivial improvements of its
code. That should be requested upstream.

Note You need to log in before you can comment on or make changes to this bug.