Bug 179409 - Smartd should not abort if it can't handle a disk
Smartd should not abort if it can't handle a disk
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: smartmontools (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-30 20:01 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 02:48:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2006-01-30 20:01:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
Smartd fails to start, because it doesn't support my SATA disk. 
However, it does seem to support my other disk. A better way to handle this is to skip one device, and monitor the other (while printing a warning that I can see during regular startup).

Opened configuration file /etc/smartd.conf
Drive: /dev/sda, implied '-a' Directive on line 35 of file /etc/smartd.conf
Configuration file /etc/smartd.conf parsed.
Device: /dev/hda, opened
Device: /dev/hda, found in smartd database.
Device: /dev/hda, is SMART capable. Adding to "monitor" list.
Device: /dev/sda, opened
Device /dev/sda, SATA disks accessed via libata are not currently supported by
smartmontools. When libata is given an ATA pass-thru ioctl() then an
additional '-d libata' device type will be added to smartmontools.
Unable to register SCSI device /dev/sda at line 35 of file /etc/smartd.conf
Unable to register device /dev/sda (no Directive -d removable). Exiting.


Version-Release number of selected component (if applicable):
smartmontools-5.33-4

How reproducible:
Always

Steps to Reproduce:
1. Install a disk accessed via libata
2. Run smartd on startup
  

Additional info:
Comment 1 Tomas Mraz 2006-01-31 02:39:25 EST
This should work fine if you use the automatically generated smartd.conf. Please
remove it and restart smartd. Then if it doesn't work, please attach the
generated smartd.conf together with the output of 'ls /sys/block'.
Comment 2 Ivan Gyurdiev 2006-01-31 02:48:08 EST
Ok, it seems to work.

Note You need to log in before you can comment on or make changes to this bug.