Bug 179412 - NetworkManager now in /usr/sbin
NetworkManager now in /usr/sbin
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-30 23:24 EST by Dan Williams
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 15:39:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Deal with relocation of NetworkManager (370 bytes, patch)
2006-01-30 23:24 EST, Dan Williams
no flags Details | Diff

  None (edit)
Description Dan Williams 2006-01-30 23:24:49 EST
Patch attached, not sure if anything else is needed.
Comment 1 Dan Williams 2006-01-30 23:24:49 EST
Created attachment 123895 [details]
Deal with relocation of NetworkManager
Comment 2 Daniel Walsh 2006-01-31 10:04:10 EST
This is fixed in Today's Rawhide.  The wpa stuff is badly broken with SELinux
though.

We need to talk about how this is supposed to work.

selinux-policy-targeted-2.2.9-1
Comment 3 Dan Williams 2006-01-31 10:12:23 EST
I committed a patch last night to NM CVS to move the socket stuff to
/var/run/NetworkManager instead of /tmp.  I'll stick that in Rawhide sometime
this week (possibly today).  Will that fix the problem?
Comment 4 Daniel Walsh 2006-01-31 10:18:41 EST
That will help, but /var/run/wpa_supplicant
directory seems to be created and removed by NetworkManager.  Is there a reason
it removes the directory or could we just remove the contents?
Comment 5 Dan Williams 2006-01-31 10:25:59 EST
	/* HACK: should be fixed in wpa_supplicant.  Will likely
	 * require accomodations for selinux.
	 */
	unlink (WPA_SUPPLICANT_GLOBAL_SOCKET);
	sock_path = supplicant_get_device_socket_path (self);
	unlink (sock_path);
	g_free (sock_path);

Yeah, mainly because wpa_supplicant doesn't seem to remove it's own sockets,
which should likely be fixed there of course.  So lets let this one slide for
the moment while I investigate why wpa_supplicant doesn't do the right thing.
Comment 6 Daniel Walsh 2006-02-14 15:39:02 EST
Seems to be working.

Fixed in selinux-policy-2.2.14-1

Note You need to log in before you can comment on or make changes to this bug.