Bug 179422 - eth0: too many iterations (6) in nv_nic_irq.
eth0: too many iterations (6) in nv_nic_irq.
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 03:13 EST by Per Steinar Iversen
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 11:10:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lsmod (2.31 KB, text/plain)
2006-02-15 16:20 EST, Per Steinar Iversen
no flags Details

  None (edit)
Description Per Steinar Iversen 2006-01-31 03:13:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
The kernel likes to print "eth0: too many iterations (6) in nv_nic_irq." all the time. This did not happen with FC4 on the same hardware.

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1881_FC5

How reproducible:
Always

Steps to Reproduce:
1.Install FC5t2
2.Get annoying messages
3.
  

Actual Results:  The system should run but not complain.

Expected Results:  The system works but like to complain about eth0.

Additional info:

The ethernet hardware uses the forcedeth driver.
lspci says:

# lspci | grep -i eth
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 15)
Comment 1 John W. Linville 2006-02-02 16:33:56 EST
The message is annoying, but not necessarily bad.  You might try the adding a 
line like this to /etc/modprobe.conf: 
 
   options forcedeth max_interrupt_work=10 
 
If the message comes back after that, it should say "too many iterations (11)" 
instead.  There is nothing magic about 10, you should experiment to find the 
lowest number that provides few or none of those messages. 
 
Please do that, and post the number here...thanks! 
Comment 2 Per Steinar Iversen 2006-02-05 07:45:34 EST
I see the message sometimes at max_interrupt_work=15 but not, so far, at
max_interrupt_work=20
Comment 4 John W. Linville 2006-02-14 11:10:32 EST
The upstream developers are aware of the issue -- hopefully they will fix it 
soon. 
 
In the meantime, it looks like you have a reasonable work-around.  Thanks for 
the report! 
Comment 5 Ayaz 2006-02-15 15:41:58 EST
Could you send me the output of "cat /proc/interrupts"?
Comment 6 Per Steinar Iversen 2006-02-15 15:46:22 EST
# cat /proc/interrupts
           CPU0
  0:   13446558    IO-APIC-edge  timer
  1:        134    IO-APIC-edge  i8042
  7:          1    IO-APIC-edge  parport0
  8:          0    IO-APIC-edge  rtc
  9:          0   IO-APIC-level  acpi
 12:        134    IO-APIC-edge  i8042
 15:     482757    IO-APIC-edge  ide1
 50:          0   IO-APIC-level  NVidia CK804
 66:          1         PCI-MSI  sky2
 74:          2   IO-APIC-level  ohci1394
217:      50725   IO-APIC-level  libata, ohci_hcd:usb1
225:    2984474   IO-APIC-level  libata, ehci_hcd:usb2
233:    5558065   IO-APIC-level  eth0
NMI:        396
LOC:   13447512
ERR:          0
MIS:          0

The current kernel is 2.6.15-1.1948_FC5
Comment 7 Ayaz 2006-02-15 15:52:19 EST
And "lsmod"?
Comment 8 Ayaz 2006-02-15 15:59:05 EST
Is there anything in particular that triggers the message? ie. running a 
particular application, etc.
Comment 9 Per Steinar Iversen 2006-02-15 16:20:15 EST
Created attachment 124704 [details]
Output of lsmod

See attachment for output of lsmod. 

The messages seems to come mostly when running yum or when the cron-jobs are
run at night - anything that stress the system a bit. Since this is running
FC5test2 the machine is just used for testing small things.

Note You need to log in before you can comment on or make changes to this bug.