Bug 179426 - in perl spec template uneeded Buildrequires perl
in perl spec template uneeded Buildrequires perl
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-rpmdevtools (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 05:29 EST by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 14:24:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-01-31 05:29:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
There is a 
BuildRequires:  perl
in 
/usr/share/fedora/spectemplate-perl.spec
but in the guidelines it is said that perl is in the unneeded 
BuildRequires.

Version-Release number of selected component (if applicable):
fedora-rpmdevtools-1.4-1.fc4

How reproducible:
Always

Steps to Reproduce:
1. nothing to reproduce
2.
3.
  

Additional info:
Comment 1 Ville Skyttä 2006-01-31 14:24:33 EST
It is unneeded as long as rpm-build and/or redhat-rpm-config pulls in perl,
that's right.  But if it some day suddenly doesn't (which I don't personally
find impossible at all), build of packages without the perl dependency would be
broken.  (Having fedora-rpmdevtools pull in perl doesn't count, the specfiles
should continue to work on systems without it installed too.)

Unless there are really strong opinions about this, I'm going to leave it in
because removing it would be "fixing" something that is not broken.
Comment 2 Patrice Dumas 2006-02-01 11:27:38 EST
In the review guidelines, not having BR perl is a must, see:

http://fedoraproject.org/wiki/Packaging/ReviewGuidelines

 - MUST: A package must not contain any BuildRequires that are listed in the
exceptions section of Packaging Guidelines. 

I find it very troubling to have something that goes against a MUST packaging
item in the fedora spec template. At least a comment should be added? Maybe the
topic should be taken on the fedora-extras list? Or is fedora-rpmdevtools not
fedora specific?
Comment 3 Ville Skyttä 2006-02-01 18:18:59 EST
If you feel strongly about it, go ahead and start discussion on the
fedora-extras list.  Note that this case is not about fedora-rpmdevtools being
Fedora specific or not per se; it's more about whether the spec template and
packages based on it are.  I'm trying to keep comments to the minimum in the
spec templates and won't add one for this.  If the consensus is that the BR:
perl must go from the spec template, I'll just drop it.  Personally I think that
the above MUST in the case of perl is a bit silly though, but mileages obviously
vary.

Note You need to log in before you can comment on or make changes to this bug.