Bug 1794311 - oc adm must-gather/inspect command throws errors "a resource cannot be retrieved by name across all namespaces" and "gathering all/openshift-monitoring"
Summary: oc adm must-gather/inspect command throws errors "a resource cannot be retrie...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks: 1811199
TreeView+ depends on / blocked
 
Reported: 2020-01-23 09:21 UTC by RamaKasturi
Modified: 2020-07-13 17:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1811199 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:13:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-authentication-operator pull 258 0 None closed Bug 1794311: Set namespace for route from related objects 2020-11-30 06:41:26 UTC
Github openshift cluster-authentication-operator pull 262 0 None closed Bug 1794311: Set namespace for service from related objects 2020-11-30 06:41:28 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:13:57 UTC

Description RamaKasturi 2020-01-23 09:21:09 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Maciej Szulik 2020-03-17 11:03:39 UTC
This was fixed in 4.5, and you performed tests on 

openshiftVersion: 4.4.0-0.nightly-2020-03-16-124852

moving back to qa.

Comment 9 zhou ying 2020-03-25 09:23:20 UTC
Can't reproduce the issue now:
[root@dhcp-140-138 roottest]# oc version -o yaml 
clientVersion:
  buildDate: "2020-03-24T22:35:38Z"
  compiler: gc
  gitCommit: ffe098c430021bb5799f61377a1a0fcf40b181a0
  gitTreeState: clean
  gitVersion: 4.5.0-202003242231-ffe098c
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64
openshiftVersion: 4.5.0-0.nightly-2020-03-24-224409


[root@dhcp-140-138 roottest]# oc adm inspect co/authentication
Gathering data for ns/openshift-config...
Gathering data for ns/openshift-config-managed...
Gathering data for ns/openshift-authentication...
Gathering data for ns/openshift-authentication-operator...
Gathering data for ns/openshift-ingress...
Wrote inspect data to inspect.local.362591389581944009.

Comment 11 errata-xmlrpc 2020-07-13 17:13:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.