Bug 179433 - system-config-users dumps core on x86_64 with ldap enabled
system-config-users dumps core on x86_64 with ldap enabled
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libuser (Show other bugs)
rawhide
noarch Linux
medium Severity high
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 06:15 EST by Pawel Salek
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 09:16:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2006-01-31 06:15:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
system-config-users dumps core on x86_64 with ldap enabled:
$ system-config-users
Traceback (most recent call last):
  File "/usr/share/system-config-users/system-config-users.py", line 45, in ?
    mainWindow.mainWindow()
  File "/usr/share/system-config-users/mainWindow.py", line 179, in __init__
    self.ADMIN = libuser.admin(prompt=admin_prompt_callback, prompt_data=(_('Logon Information Required'),))
SystemError: /usr/lib/libuser/libuser_ldap.so: cannot open shared object file: No such file or directory

libuser library is installed but the library files are in /usr/lib64/libuser.

Version-Release number of selected component (if applicable):
system-config-users-1.2.41-1.1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.a
  

Actual Results:  a

Expected Results:  a

Additional info:

a
Comment 1 Nils Philippsen 2006-01-31 07:29:25 EST
This is very probably a libuser problem.

NB: It doesn't dump core, it throws an exception.
Comment 2 Miloslav Trmač 2006-01-31 08:43:00 EST
What is the output of (grep moduledir /etc/libuser.conf) ?
Comment 3 Pawel Salek 2006-01-31 09:09:32 EST
nice catch!
$ grep moduledir /etc/libuser.conf
moduledir = /usr/lib/libuser

Does this mean this file is architecture dependent? I just have a number of
boxes, some of them 32-bit and some of them 64-bit and I kind of hoped they
could share the user database in some easy way...
Comment 4 Miloslav Trmač 2006-01-31 09:16:35 EST
No, it means you are carrying around an old libuser.conf.  Since libuser-0.51.11
the installed config file contains:

[defaults]
# The default (/usr/lib*/libuser) is usually correct
# moduledir = /your/custom/directory


Just comment the moduledir line out and everything should work correctly.

Note You need to log in before you can comment on or make changes to this bug.