Bug 1794338 - samba fails to build: Checking for system pyldb-util.cpython-39-x86_64-linux-gnu fails
Summary: samba fails to build: Checking for system pyldb-util.cpython-39-x86_64-linux-...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FTBFS PYTHON39
TreeView+ depends on / blocked
 
Reported: 2020-01-23 10:35 UTC by Miro Hrončok
Modified: 2020-01-29 09:19 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-29 09:19:05 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-01-23 10:35:53 UTC
samba fails to build with Python 3.9.0a2.

Checking for system pyldb-util.cpython-39-x86_64-linux-gnu (>=2.0.8 <=2.0.999)    : not found 
ERROR: Use of system library ldb depends on missing system library/libraries ['pyldb-util.cpython-39-x86_64-linux-gnu']

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01176818-samba/

For all our attempts to build samba with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/samba/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Petr Pisar 2020-01-23 11:54:05 UTC
This already happens in Fedora 32 <https://koschei.fedoraproject.org/build/7780018>. Probably because of upgrading python3-ldb-devel from 2.0.8-1.fc32 to 2.1.0-1.fc3.

Comment 2 Alexander Bokovoy 2020-01-29 09:19:05 UTC
This is not a bug. Your attempt to rebuild Samba failed because it happened at the moment when Samba 4.12 was being added to rawhide. The latter required a temporary compose break to first build ldb library. We wish it could have been done via a sidetag but that didn't happen and thus it is just a coincidence.

Since that time, we already rebuilt Samba 4.12 against krb5 which also had been an ABI change (in a sidetag) and it built just fine.


Note You need to log in before you can comment on or make changes to this bug.