Bug 179435 - /usr/bin/rebuild-gcj-db hangs
/usr/bin/rebuild-gcj-db hangs
Status: CLOSED DUPLICATE of bug 179002
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 07:30 EST by Gene Czarcinski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 11:07:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2006-01-31 07:30:41 EST
Description of problem:

Attemtping to update eclipse on a fc5t2 x86_86 install hung up.  Running down
what is hanging, it appears to be usr/bin/rebuild-gcj-db ... even when manually
invoked.

Doing the same thing on a fc5f2 i386 install (but x86_64 hardware), and
everything works OK.

Installed: java-1.4.2-gcj-compat-1.4.2.0-40jpp_61rh

and for eclipse-* 3.1.1-1jpp_15fc.x86_64 -> .1.1-1jpp_16fc.x86_64
Comment 1 Ivan Gyurdiev 2006-01-31 10:59:52 EST
Confirming bug with: java-1.4.2-gcj-compat-1.4.2.0-40jpp_63rh
gcj-dbtool is hanging on many .db files.
Here are some of them in lib64/gcj (minus the .bak):

ant/ant-1.6.5.jar.db.bak
ant/ant-apache-bcel-1.6.5.jar.db.bak
ant/ant-launcher-1.6.5.jar.db.bak
ant/ant-nodeps-1.6.5.jar.db.bak
ant/ant-trax-1.6.5.jar.db.bak
azureus/Azureus2.jar.db.bak
eclipse-cdt/cdtcore.jar.db.bak
eclipse-cdt/cdtdebugcore.jar.db.bak
eclipse-cdt/cdtdebugui.jar.db.bak
eclipse-cdt/cdtlaunch.jar.db.bak
eclipse-cdt/cdtmakecore.jar.db.bak
eclipse-cdt/cdtmakeui.jar.db.bak
eclipse-cdt/cdtmicore.jar.db.bak
eclipse-cdt/cdtmiui.jar.db.bak
eclipse-cdt/cdtparser.jar.db.bak
eclipse-cdt/cdtui.jar.db.bak
eclipse-cdt/gnuui.jar.db.bak
eclipse-cdt/mgdbuildui.jar.db.bak
eclipse-cdt/mngbuildcore.jar.db.bak
hsqldb/hsqldb-1.80.1.jar.db.bak
jakarta-commons-beanutils/jakarta-commons-beanutils-1.7.0.jar.db.bak
jakarta-commons-collections/jakarta-commons-collections-3.1.jar.db.bak
jakarta-commons-digester/jakarta-commons-digester-1.6.jar.db.bak
jakarta-commons-digester/jakarta-commons-digester-1.6-rss.jar.db.bak
lucene/lucene-1.4.3.jar.db.bak
lucene/lucene-demos-1.4.3.jar.db.bak
mx4j/mx4j-3.0.1.jar.db.bak
mx4j/mx4j-remote-boa-3.0.1.jar.db.bak
mx4j/mx4j-tools-3.0.1.jar.db.bak
struts/struts-1.2.4.jar.db.bak
struts/struts-examples_classes.jar.db.bak
xerces-j2/xerces-j2-2.6.2.jar.db.bak
xerces-j2/xerces-j2-samples.jar.db.bak
xmlrpc/xmlrpc-applet-2.0.1.jar.db.bak
Comment 2 Thomas Fitzsimmons 2006-01-31 11:07:31 EST

*** This bug has been marked as a duplicate of 179002 ***

Note You need to log in before you can comment on or make changes to this bug.