Bug 1794369 - Network port on X1C7 CometLake SVT system does not work
Summary: Network port on X1C7 CometLake SVT system does not work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1796097
TreeView+ depends on / blocked
 
Reported: 2020-01-23 12:26 UTC by David Ober
Modified: 2020-03-04 14:57 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1796097 (view as bug list)
Environment:
Last Closed: 2020-03-04 14:57:30 UTC
Type: Bug


Attachments (Terms of Use)
requested journalctl output (86.84 KB, text/plain)
2020-01-23 12:26 UTC, David Ober
no flags Details

Description David Ober 2020-01-23 12:26:20 UTC
Created attachment 1654834 [details]
requested journalctl output

1. Please describe the problem:The netwrk port on the side of the X1C7 does not enable, youi can use wifi or USB by the built in network port is not working, this does work on the SIT model but not the SVT, it also does not work onthe newe X1C8 SIT model


2. What is the Version-Release number of the kernel:5.3.7-301


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below: boot system lspci shows network device gnome networks does not


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``: Did not test as needs to be on the production release


6. Are you running any modules that not shipped with directly Fedora's kernel?:
no

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 David Ober 2020-01-23 13:28:45 UTC
For reference the pciid for the SVT network card which has the I219-V is 8086:0d4f whereas the SIT has the I219-LM at 8086:15bd

Comment 2 David Ober 2020-01-23 14:04:35 UTC
Based on the data found below the updated driver is in 5.5 kernel for the two nic cards in the X1C7 CMT SVT and X1C8 SIT


lkddb pci 8086 0d4e .... .... ...... : CONFIG_E1000E CONFIG_ETHERNET CONFIG_NET_VENDOR_INTEL : drivers/net/ethernet/intel/e1000e/netdev.c # in 5.5-rc+HEAD
lkddb pci 8086 0d4f .... .... ...... : CONFIG_E1000E CONFIG_ETHERNET CONFIG_NET_VENDOR_INTEL : drivers/net/ethernet/intel/e1000e/netdev.c # in 5.5-rc+HEAD

Comment 4 Justin M. Forbes 2020-03-03 16:22:24 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 31 kernel bugs.

Fedora 31 has now been rebased to 5.5.7-200.fc31.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 32, and are still experiencing this issue, please change the version to Fedora 32.

If you experience different issues, please open a new bug report for those.

Comment 5 David Ober 2020-03-03 19:28:37 UTC
this has been added into the 5.4.17 kernelk so this ticket can be closed

Comment 6 Justin M. Forbes 2020-03-04 14:57:30 UTC
Thank you for the update.


Note You need to log in before you can comment on or make changes to this bug.