Bug 1794391 - NM.Client leaking on opened file descriptor
Summary: NM.Client leaking on opened file descriptor
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: 8.2
Assignee: Thomas Haller
QA Contact: Desktop QE
URL:
Whiteboard:
: 1777798 (view as bug list)
Depends On:
Blocks: nmstate-nm
TreeView+ depends on / blocked
 
Reported: 2020-01-23 13:38 UTC by Gris Ge
Modified: 2020-04-28 16:54 UTC (History)
10 users (show)

Fixed In Version: NetworkManager-1.22.6-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:54:11 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Reproduce script (1.51 KB, text/x-python)
2020-01-23 13:38 UTC, Gris Ge
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:38 UTC

Description Gris Ge 2020-01-23 13:38:07 UTC
Created attachment 1654848 [details]
Reproduce script

Description of problem:

Will hit the maximum open fd.

Version-Release number of selected component (if applicable):
NetworkManager-1.22.0-2.el8.x86_64.rpm

How reproducible:
100%

Steps to Reproduce:
1. sudo ./nm_client_cleanup.py
2.
3.

Actual results:

Crash as hit the maximum opened descriptor

Expected results:
No crash

Additional info:

Comment 1 Beniamino Galvani 2020-01-29 15:00:19 UTC
*** Bug 1777798 has been marked as a duplicate of this bug. ***

Comment 2 Thomas Haller 2020-02-16 13:26:35 UTC
this should be fixed on master (1.23.x) and 1.22.6+ (commit c2f8400e6606918873505280d0edff3577e7d7ab).

Comment 6 Vladimir Benes 2020-02-18 13:02:42 UTC
this is covered by nmstate's test:
tests/integration/mem_leak_test.py::test_libnmstae_show_fd_leak

Comment 8 errata-xmlrpc 2020-04-28 16:54:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.