Bug 179448 - ia64: unaligned access errors seen during startup of avahi-daemon
ia64: unaligned access errors seen during startup of avahi-daemon
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks: fedora-ia64 206445
  Show dependency treegraph
 
Reported: 2006-01-31 09:50 EST by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 06:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-01-31 09:50:21 EST
Description of problem: 
 
Whe the avahi-daemon starts, unaligned access errors are sent to the console. 
 
Version-Release number of selected component (if applicable): 
 
avahi-0.6.5-1 from latest devel builds 
 
How reproducible: 100% 
 
 
Steps to Reproduce: 
1. boot system 
   
Actual results: 
 
 avahi-daemon(28929): unaligned access to 0x60000fffffeef2c4, 
ip=0x20000000000b20c1 
avahi-daemon(28929): unaligned access to 0x60000fffffeef2e4, 
ip=0x20000000000b1ec0 
avahi-daemon(28929): unaligned access to 0x60000fffffeef2e4, 
ip=0x20000000000b2061 
avahi-daemon(28929): unaligned access to 0x60000fffffeef2c4, 
ip=0x20000000000b20c1 
 
Expected results: 
 
No warnings should be seen. 
 
Additional info: 
 
I haven't had much time to debug further.  gdb output that is probably useful: 
 
[root@altix2 home]# prctl --unaligned=signal gdb /usr/sbin/avahi-daemon 
GNU gdb Red Hat Linux (6.3.0.0-1.98rh) 
Copyright 2004 Free Software Foundation, Inc. 
GDB is free software, covered by the GNU General Public License, and you are 
welcome to change it and/or distribute copies of it under certain conditions. 
Type "show copying" to see the conditions. 
There is absolutely no warranty for GDB.  Type "show warranty" for details. 
This GDB was configured as "ia64-redhat-linux-gnu"... 
(no debugging symbols found) 
Using host libthread_db library "/lib/libthread_db.so.1". 
 
(gdb) run 
Starting program: /usr/sbin/avahi-daemon  
Reading symbols from shared object read from target memory...(no debugging 
symbols found)...done. 
Loaded system supplied DSO at 0xa000000000000000 
(no debugging symbols found) 
(no debugging symbols found) 
(no debugging symbols found) 
(no debugging symbols found) 
(no debugging symbols found) 
(no debugging symbols found) 
(no debugging symbols found) 
(no debugging symbols found) 
(no debugging symbols found) 
(no debugging symbols found) 
[Thread debugging using libthread_db enabled] 
[New Thread 2305843009219350000 (LWP 28957)] 
(no debugging symbols found) 
(no debugging symbols found) 
Found user 'avahi' (UID 70) and group 'avahi' (GID 70). 
Successfully dropped root privileges. 
Detaching after fork from child process 28960. 
avahi-daemon 0.6.5 starting up. 
WARNING: No NSS support for mDNS detected, consider installing nss-mdns! 
Successfully called chroot(). 
Successfully dropped remaining capabilities. 
Failed to read service directory. 
New relevant interface eth0.IPv4 for mDNS. 
Joining mDNS multicast group on interface eth0.IPv4 with address 
192.168.79.54. 
Network interface enumeration completed. 
Registering new address record for 192.168.79.54 on eth0. 
Registering HINFO record with values 'IA64'/'LINUX'. 
 
Program received signal SIGBUS, Bus error. 
[Switching to Thread 2305843009219350000 (LWP 28957)] 
0x20000000000b20c1 in avahi_recv_dns_packet_ipv4 () 
   from /usr/lib/libavahi-core.so.3 
(gdb) trace 
trace command requires an argument 
(gdb) where 
#0  0x20000000000b20c1 in avahi_recv_dns_packet_ipv4 () 
   from /usr/lib/libavahi-core.so.3 
#1  0x20000000000a26c0 in mcast_socket_event () 
   from /usr/lib/libavahi-core.so.3 
#2  0x2000000000070300 in avahi_simple_poll_dispatch () 
   from /usr/lib/libavahi-common.so.3 
#3  0x2000000000071160 in avahi_simple_poll_iterate () 
   from /usr/lib/libavahi-common.so.3 
#4  0x4000000000009390 in ?? () 
Previous frame inner to this frame (corrupt stack?) 
(gdb)
Comment 1 Prarit Bhargava 2006-01-31 11:08:01 EST
Jason, if you require an ia64 box to test on please let me know. 
 
P. 
Comment 3 Jason Vas Dias 2006-01-31 14:39:53 EST
Hi Prarit - yes, please can you send access details for an ia64 FC-5 box -
I can't reproduce this problem on any box here - we have no ia64 FC-5 systems
in the lab.
Thanks & Regards,
Jason

Comment 4 Prarit Bhargava 2006-02-01 12:00:21 EST
Jason, I'm reinstalling altix2.lab with the latest Fedora Core devel on it. 
 
I'll email you instructions when it's up and running... 
 
P. 
Comment 5 Jason Vas Dias 2006-02-01 18:29:22 EST
Thanks Prarit - all done with altix2 now - this bug is fixed with avahi-0.6.6-1 .
Comment 6 Jason Vas Dias 2006-02-01 18:39:31 EST
Upstream bug ticket #9 opened on this issue: http://avahi.org/ticket/9 
Comment 7 Aron Griffis 2006-08-16 23:09:54 EDT
I still see these with avahi-0.6.11-2.fc6

avahi-daemon(1647): unaligned access to 0x60000fffff2e3634, ip=0x200000000009e600
avahi-daemon(1647): unaligned access to 0x60000fffff2e3634, ip=0x200000000009e6c1
avahi-daemon(1647): unaligned access to 0x60000fffff2e3634, ip=0x200000000009e600
avahi-daemon(1647): unaligned access to 0x60000fffff2e3634, ip=0x200000000009e6c1
avahi-daemon(1647): unaligned access to 0x60000fffff2e3634, ip=0x200000000009e600
avahi-daemon(1647): unaligned access to 0x60000fffff2e3634, ip=0x200000000009e600
avahi-daemon(1647): unaligned access to 0x60000fffff2e3634, ip=0x200000000009e6c1
Comment 8 Martin Stransky 2006-09-18 06:44:32 EDT
It should be fixed in avahi-0.6.11-6.fc6

Note You need to log in before you can comment on or make changes to this bug.