Bug 1794506 - New version : v6.3.0
Summary: New version : v6.3.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: clamav-unofficial-sigs
Version: 31
Hardware: All
OS: All
unspecified
unspecified
Target Milestone: ---
Assignee: Didier Fabert (tartare)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1794652 1794887 1796034 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-23 17:51 UTC by Jan ONDREJ
Modified: 2020-02-15 02:34 UTC (History)
9 users (show)

Fixed In Version: clamav-unofficial-sigs-7.0-1.el7 clamav-unofficial-sigs-7.0.1-1.el7 clamav-unofficial-sigs-7.0.1-1.fc30 clamav-unofficial-sigs-7.0.1-1.fc31 clamav-unofficial-sigs-7.0.1-1.el8 clamav-unofficial-sigs-7.0.1-2.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-30 23:43:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan ONDREJ 2020-01-23 17:51:01 UTC
Description of problem:
Today started to send periodic messages from clamav-unofficial-sigs, that new version is available.

Version-Release number of selected component (if applicable):
clamav-unofficial-sigs-6.1.1-2.fc31.noarch
clamav-unofficial-sigs-6.1.1-2.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. /usr/sbin/clamav-unofficial-sigs.sh

Actual results:
***********************************************************************************
ALERT: New version : v6.3.0 @ https://github.com/extremeshok/clamav-unofficial-sigs
***********************************************************************************
***************************************************************************************
ALERT: New config version : v81 @ https://github.com/extremeshok/clamav-unofficial-sigs
***************************************************************************************


Expected results:
Do not report this by emai.

Additional info:
Please update to latest version and then try to fix these messages.

Comment 1 Robert Scheck 2020-01-24 00:24:41 UTC
Can you please patch out these version checks? I think it should be a package maintainers job to provide a current version. As an administrator I trust you, as package maintainer, and thus I do not want to get "new version" spam all over.

Comment 2 Robert Scheck 2020-01-24 00:31:29 UTC
Emptying check_new_version() and check_new_config_version() functions in /usr/sbin/clamav-unofficial-sigs.sh seems to do the trick, and that's what I would like to see in the RPM package (until upstream provides a nice feature to not play mad with RPM downstreams).

Comment 3 Jan ONDREJ 2020-01-24 08:37:18 UTC
This worked well for me as an workaround on all my servers:

sed -i 's/^check_new_/#check_new_/' /usr/sbin/clamav-unofficial-sigs.sh

I will try to update this package and add this, but it will be better to still display this, but only in logfile. Not sure how to implement this now.

Comment 4 Jan ONDREJ 2020-01-24 08:45:12 UTC
Problem has been reported upstream:

  https://github.com/extremeshok/clamav-unofficial-sigs/issues/281

Looks like there is no new release available, this script only checks git version, not an official release, so I can't do an update now.

I can only apply my workaround to an fedora/centos/rhel release of clamav-unofficial-sigs, if needed.

Comment 5 Jan ONDREJ 2020-01-24 09:01:52 UTC
*** Bug 1794652 has been marked as a duplicate of this bug. ***

Comment 6 Robert Scheck 2020-01-24 13:25:54 UTC
Yes, please apply your workaround to updated packages of clamav-unofficial-sigs for all Fedora and EPEL branches...I'm getting flooded. The function xshok_pretty_echo_and_log() (which is used by check_new_version() and check_new_config_version()) is IMHO a strange hack by upstream which only supports displaying and logging.

Comment 7 Jan ONDREJ 2020-01-24 13:27:50 UTC
According to upstream, currently this is fixed by reverting version on github. Do you still have problems? If yes, you can use my workaround, which will be rewritten by updated package later.

Comment 8 Robert Scheck 2020-01-24 14:05:50 UTC
As stated in https://github.com/extremeshok/clamav-unofficial-sigs/issues/281#issuecomment-578129830, upstream's workaround is just doing half of the solution. I'm already using your workaround, but it's still affecting enough systems ;-(

Please adapt https://github.com/extremeshok/clamav-unofficial-sigs/issues/281#issuecomment-578135668 as mentioned in https://github.com/extremeshok/clamav-unofficial-sigs/issues/281#issuecomment-578142063 for the next updated packages.

Comment 9 Jan ONDREJ 2020-01-25 05:11:55 UTC
*** Bug 1794887 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2020-01-25 06:00:31 UTC
FEDORA-2020-49dd0271ac has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-49dd0271ac

Comment 11 Fedora Update System 2020-01-25 06:04:50 UTC
FEDORA-2020-1b1ddf045c has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-1b1ddf045c

Comment 12 Fedora Update System 2020-01-25 06:20:50 UTC
FEDORA-EPEL-2020-b86f54cbf1 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b86f54cbf1

Comment 13 Fedora Update System 2020-01-26 01:14:41 UTC
clamav-unofficial-sigs-7.0-1.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-3df1877be5

Comment 14 Fedora Update System 2020-01-26 01:17:33 UTC
clamav-unofficial-sigs-7.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b86f54cbf1

Comment 15 Fedora Update System 2020-01-26 01:52:10 UTC
clamav-unofficial-sigs-7.0-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-1b1ddf045c

Comment 16 Fedora Update System 2020-01-27 07:06:43 UTC
FEDORA-2020-ceb596822e has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-ceb596822e

Comment 17 Fedora Update System 2020-01-27 07:10:41 UTC
FEDORA-2020-edc1729869 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-edc1729869

Comment 18 Fedora Update System 2020-01-27 07:16:01 UTC
FEDORA-EPEL-2020-d7aed7ad21 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-d7aed7ad21

Comment 19 Fedora Update System 2020-01-27 13:12:39 UTC
FEDORA-EPEL-2020-9af7a79547 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-9af7a79547

Comment 20 Amir Caspi 2020-01-28 02:04:20 UTC
FTR, upstream now has v7.0.1 available.  The v7.x releases have a --upgrade flag that will enable future updates automatically ... not sure if this is desirable or not from a package standpoint, so maintainers may wish to patch source to include a warning message when using --upgrade that it will no longer match the installed RPM info.

Comment 21 Jan ONDREJ 2020-01-28 06:16:40 UTC
(In reply to Amir Caspi from comment #20)
> FTR, upstream now has v7.0.1 available.  The v7.x releases have a --upgrade
> flag that will enable future updates automatically ... not sure if this is
> desirable or not from a package standpoint, so maintainers may wish to patch
> source to include a warning message when using --upgrade that it will no
> longer match the installed RPM info.

We have 7.0.1 too in testing.

According to warning, try to report upstream. No planning to do similar changes in rpm.

Comment 22 Amir Caspi 2020-01-28 06:20:14 UTC
(In reply to Jan ONDREJ from comment #21)
> According to warning, try to report upstream. No planning to do similar
> changes in rpm.

I'm not sure what you mean -- upstream doesn't have any package maintenance and included the --upgrade flag presumably so that users could upgrade easily... but any users who are using packages (e.g., distro users) likely wish to upgrade through normal channels (e.g., yum).  Upstream wouldn't print a warning message that applies only to distro users, I would imagine the package maintainers would have to do that, no?  Am I misunderstanding?

Comment 23 Jan ONDREJ 2020-01-28 06:25:22 UTC
(In reply to Amir Caspi from comment #22)
> I'm not sure what you mean -- upstream doesn't have any package maintenance
> and included the --upgrade flag presumably so that users could upgrade
> easily... but any users who are using packages (e.g., distro users) likely
> wish to upgrade through normal channels (e.g., yum).  Upstream wouldn't
> print a warning message that applies only to distro users, I would imagine
> the package maintainers would have to do that, no?  Am I misunderstanding?

Upstream has packaging support. See this:
  https://github.com/extremeshok/clamav-unofficial-sigs/tree/master/config/packaging
He can check, if upgrades have been disabled in os.conf and then show a warning.

Btw, I am not a main admin of this package. Doing basic updates but not planning to do big changes, which will be harder to maintain. Package without patches is easy to maintain.

Comment 24 Jan ONDREJ 2020-01-29 13:41:56 UTC
*** Bug 1796034 has been marked as a duplicate of this bug. ***

Comment 25 Fedora Update System 2020-01-30 22:59:23 UTC
clamav-unofficial-sigs-7.0-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-49dd0271ac

Comment 26 Fedora Update System 2020-01-30 23:43:35 UTC
clamav-unofficial-sigs-7.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2020-01-30 23:43:36 UTC
clamav-unofficial-sigs-7.0.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2020-01-31 01:28:24 UTC
clamav-unofficial-sigs-7.0.1-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-ceb596822e

Comment 29 Fedora Update System 2020-01-31 02:04:54 UTC
clamav-unofficial-sigs-7.0.1-1.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-d7aed7ad21

Comment 30 Fedora Update System 2020-01-31 02:25:16 UTC
clamav-unofficial-sigs-7.0.1-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-edc1729869

Comment 31 Fedora Update System 2020-01-31 02:56:47 UTC
clamav-unofficial-sigs-7.0.1-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-9af7a79547

Comment 32 Fedora Update System 2020-02-08 01:37:07 UTC
clamav-unofficial-sigs-7.0.1-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 33 Fedora Update System 2020-02-08 01:59:48 UTC
clamav-unofficial-sigs-7.0.1-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 34 Fedora Update System 2020-02-15 00:15:44 UTC
clamav-unofficial-sigs-7.0.1-1.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.

Comment 35 Fedora Update System 2020-02-15 02:34:29 UTC
clamav-unofficial-sigs-7.0.1-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.