Bug 1794516 - oc: error: No Auth Provider found for name "gcp"
Summary: oc: error: No Auth Provider found for name "gcp"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: All
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: David Eads
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks: 1795302
TreeView+ depends on / blocked
 
Reported: 2020-01-23 18:06 UTC by Steve Kuznetsov
Modified: 2020-05-04 11:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1795302 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:26:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 266 None closed bug 1794516: initialize auth plugins 2020-05-11 09:44:21 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:27:08 UTC

Description Steve Kuznetsov 2020-01-23 18:06:34 UTC
Configure a GKE cluster auth in a config:

$ yq .users[0] < ~/.kube/prow
users:
- name: gke_k8s-prow-builds_us-central1-f_prow
  user:
    auth-provider:
      config:
        access-token: xxx
        cmd-args: config config-helper --format=json
        cmd-path: /home/skuznets/google-cloud-sdk/bin/gcloud
        expiry: "2019-08-06T18:08:09Z"
        expiry-key: '{.credential.token_expiry}'
        token-key: '{.credential.access_token}'
      name: gcp

Run a command:

$ KUBECONFIG=~/.kube/prow kubectl get pods
error: No Auth Provider found for name "gcp"


$ oc version
Client Version: v4.2.14
Kubernetes Version: v1.11.0+d4cacc0

Comment 5 Steve Kuznetsov 2020-02-14 17:47:21 UTC
Broken before:

$ oc version
Client Version: v4.2.14
Kubernetes Version: v1.11.0+d4cacc0

$ KUBECONFIG=~/.kube/prow oc version
error: No Auth Provider found for name "gcp"

================================

Fixed now:

$ oc_bz_1794516 version
Client Version: 4.4.0-0.nightly-2020-02-13-124128
Kubernetes Version: v1.11.0+d4cacc0

$ KUBECONFIG=~/.kube/prow oc_bz_1794516 version
Client Version: 4.4.0-0.nightly-2020-02-13-124128
Kubernetes Version: v1.14.8-gke.33


From my testing, this client works:

https://mirror.openshift.com/pub/openshift-v4/clients/ocp-dev-preview/4.4.0-0.nightly-2020-02-13-124128/

Comment 6 zhou ying 2020-02-17 01:01:33 UTC
Confirmed from email, the issue has fixed.

Comment 8 errata-xmlrpc 2020-05-04 11:26:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.