Bug 179458 - kded segfaults for audio cd's
kded segfaults for audio cd's
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 10:58 EST by Sammy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 08:15:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kde-3.5.1 version of dbus patch (114.08 KB, patch)
2006-01-31 18:12 EST, Sammy
no flags Details | Diff

  None (edit)
Description Sammy 2006-01-31 10:58:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Kded works fine for regular linux or windows cd's but
when an audio cd is inserted it keeps segfaulting for
about every 2 seconds until cd is manually ejected.

I went into kde bug database and guys told me that this
has to do with mediamanager hal backend.

Before pursuing it there I wanted to make sure this is
not due to qt/hal inclusion in Fedora FC5-devel or hal
in FC5 devel. Could you confirm this for me?

Also, I did update everything to the KDE 3.5.1 tag and have
the same problem as in 3.5.0 (used all the most recent
rawhide spec files to build 3.5.1).

Thanks
Umar



Version-Release number of selected component (if applicable):
kdelibs-3.5.0-5

How reproducible:
Always

Steps to Reproduce:
1. Update to latest rawhide
2. insert an audio cd
3.
  

Additional info:
Comment 1 Ngo Than 2006-01-31 12:04:37 EST
The dbus package in rawhide does not include dbus-qt-bindings, so the hal
backend in mediamanager will be disable in this case when you build new kde-3.5.1.

I have done some hacks to get dbus/hal support in kdebase-3.5.0-3, which
is available in rawhide now. Could you please try latest rawhide again? Thanks

you should please check if autorun is enable
($HOME/.kde/Autostart/Autorun.desktop) if yes please remove the Autorun.desktop
before starting KDE.
Comment 2 Sammy 2006-01-31 15:21:40 EST
 
kdebase-3.5.0 did not make it to rawhide for some reason! I saw it in cvs
already a few days ago. The patch applies pretty much to 3.5.1 with only
the .desktop file changes being removed (already in 3.5.1).

Looking into coolos_media stuff I notice that he made some critical changes
to halbackend.cpp in the last 29 hours. I'll see if these can be incorporated
and also I'll try your 3.5.0 whenever it hits rawhide.

I really want to get to the bottom of this because I read some place that it
could be a kernel bug but I could never find the claimed patch (andrew morton).
Comment 3 Sammy 2006-01-31 18:12:15 EST
Created attachment 123942 [details]
kde-3.5.1 version of dbus patch
Comment 4 Sammy 2006-01-31 18:13:00 EST
OK. The latest changes from Coolo fixed the problem...wonderful. I tried
it out for 3.5.1. The changed files are: mediaimpl.cpp, halbackend.cpp,
and medianotifier.cpp. I am very satisfied....it actually detected a music
cd and asked if I would like to play it!

The patch for 3.5.1 is attached.
Thanks
Comment 5 Ngo Than 2006-02-01 08:15:56 EST
it's now fixed in kdebase-3.5.1-1, which will be available in rawhide soon. Thanks
for your report.

Note You need to log in before you can comment on or make changes to this bug.