Bug 179464 - freeglut-devel should Requires: libGL-devel, libGLU-devel
freeglut-devel should Requires: libGL-devel, libGLU-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: freeglut (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 11:35 EST by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 03:11:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2006-01-31 11:35:15 EST
/usr/include/freeglut/freeglut_std.h contains:
#include <GL/gl.h>
#include <GL/glu.h>

so freeglut-devel should 
Requires: libGL-devel libGLU-devel
Comment 1 Rex Dieter 2006-01-31 11:40:03 EST
Oops, that should be /usr/include/GL/freeglut_std.h
Comment 2 Mike A. Harris 2006-02-01 03:11:08 EST
Previously I had already added:

# We BuildRequires the gl.h header here, because any GL implementation will
# suffice, and there is no widespread accepted "standard" for a OpenGL
# virtual Provides.
BuildRequires: /usr/include/GL/gl.h

However that is build time, rather than freeglut-devel runtime.  Now that
modular has landed though, and "libGL", "libGLU" etc. are the new standard
name in town, I think it is plausible to start using these virtual
provides instead of the file based one currently used.

That makes it easier to add Requires to -devel and maintain a single standard
as well, however it may make the freeglut 2.4.0 package more of a pain to
rebuild on older OS releases.  Weighing all factors though, such is often
the price in the persuit of forward moving progress.  ;o)

Fixed in 2.4.0-3 in rawhide.


Note You need to log in before you can comment on or make changes to this bug.