Bug 1794678 - oc adm must-gather does not collect endpoints for openshift-cluster-machine-approver
Summary: oc adm must-gather does not collect endpoints for openshift-cluster-machine-a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Alberto
QA Contact: Paige Rubendall
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-24 10:20 UTC by RamaKasturi
Modified: 2020-07-13 17:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:13:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-machine-approver pull 71 0 None closed Bug 1794678: Add clusteroperator status 2020-06-23 08:21:14 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:13:57 UTC

Description RamaKasturi 2020-01-24 10:20:04 UTC
Description of problem:
Running the command oc adm must-gather does not collect endpoints for openshift-cluster-machine-approver. But i do see that endpoints are present for this when running the command below.

[ramakasturinarra@dhcp35-60 ~]$ oc get endpoints -n openshift-cluster-machine-approver
NAME               ENDPOINTS          AGE
machine-approver   10.0.163.33:9192   3h58m

Version-Release number of selected component (if applicable):
[ramakasturinarra@dhcp35-60 ~]$ oc version -o yaml
clientVersion:
  buildDate: ""
  compiler: gc
  gitCommit: ""
  gitTreeState: ""
  gitVersion: unknown
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64
openshiftVersion: 4.4.0-0.nightly-2020-01-24-023332
serverVersion:
  buildDate: "2020-01-23T22:07:55Z"
  compiler: gc
  gitCommit: cb58b1a
  gitTreeState: clean
  gitVersion: v1.17.1
  goVersion: go1.13.4
  major: "1"
  minor: 17+
  platform: linux/amd64


How reproducible:
Always

Steps to Reproduce:
1. Install cluster using latest payload
2. Run the command oc adm must-gather
3. check if must-gather has collected endpoints for all

Actual results:
I see that endpoints has not been collected for openshift-cluster-machine-approver

Expected results:
Endpoints should be collected for openshift-cluster-machine-approver.

Additional info:

endpoints collected when oc adm must-gather was run

[ramakasturinarra@dhcp35-60 quay-io-openshift-release-dev-ocp-v4-0-art-dev-sha256-dba76d477694aaf1a0207a24a5ab01b2b2c13622f1faae4ac7838a143e21b865]$ find . -name "*endpoints*"
./namespaces/openshift-authentication/core/endpoints.yaml
./namespaces/openshift-console/core/endpoints.yaml
./namespaces/openshift-kube-apiserver-operator/core/endpoints.yaml
./namespaces/default/core/endpoints.yaml
./namespaces/openshift-network-operator/core/endpoints.yaml
./namespaces/openshift-multus/core/endpoints.yaml
./namespaces/openshift/core/endpoints.yaml
./namespaces/openshift-kube-storage-version-migrator/core/endpoints.yaml
./namespaces/openshift-cluster-version/core/endpoints.yaml
./namespaces/openshift-etcd/core/endpoints.yaml
./namespaces/openshift-kube-controller-manager/core/endpoints.yaml
./namespaces/openshift-monitoring/core/endpoints.yaml
./namespaces/openshift-image-registry/core/endpoints.yaml
./namespaces/openshift-operator-lifecycle-manager/core/endpoints.yaml
./namespaces/openshift-ingress-operator/core/endpoints.yaml
./namespaces/openshift-config-managed/core/endpoints.yaml
./namespaces/openshift-kube-storage-version-migrator-operator/core/endpoints.yaml
./namespaces/openshift-cluster-node-tuning-operator/core/endpoints.yaml
./namespaces/openshift-service-catalog-controller-manager-operator/core/endpoints.yaml
./namespaces/openshift-csi-snapshot-controller/core/endpoints.yaml
./namespaces/openshift-kube-scheduler/core/endpoints.yaml
./namespaces/openshift-kube-scheduler-operator/core/endpoints.yaml
./namespaces/openshift-machine-api/core/endpoints.yaml
./namespaces/openshift-console-operator/core/endpoints.yaml
./namespaces/openshift-apiserver-operator/core/endpoints.yaml
./namespaces/openshift-cluster-samples-operator/core/endpoints.yaml
./namespaces/openshift-marketplace/core/endpoints.yaml
./namespaces/openshift-service-ca/core/endpoints.yaml
./namespaces/openshift-dns/core/endpoints.yaml
./namespaces/openshift-config/core/endpoints.yaml
./namespaces/openshift-sdn/core/endpoints.yaml
./namespaces/openshift-service-catalog-apiserver-operator/core/endpoints.yaml
./namespaces/openshift-service-ca-operator/core/endpoints.yaml
./namespaces/openshift-ingress/core/endpoints.yaml
./namespaces/openshift-dns-operator/core/endpoints.yaml
./namespaces/openshift-insights/core/endpoints.yaml
./namespaces/openshift-controller-manager/core/endpoints.yaml
./namespaces/kube-system/core/endpoints.yaml
./namespaces/openshift-machine-config-operator/core/endpoints.yaml
./namespaces/openshift-controller-manager-operator/core/endpoints.yaml
./namespaces/openshift-kube-controller-manager-operator/core/endpoints.yaml
./namespaces/openshift-cluster-storage-operator/core/endpoints.yaml
./namespaces/openshift-authentication-operator/core/endpoints.yaml
./namespaces/openshift-apiserver/core/endpoints.yaml
./namespaces/openshift-cloud-credential-operator/core/endpoints.yaml
./namespaces/openshift-kube-apiserver/core/endpoints.yaml

Comment 1 Maciej Szulik 2020-01-28 15:48:13 UTC
Which parts of the data are being scraped is defined by the operator. Moving to the owners of the machine operator.

Comment 6 Paige Rubendall 2020-05-08 18:20:46 UTC
I was able verify that I can see the openshift-cluster-machine-approver endpoint getting produced from the "oc adm must-gather" command. 


Steps to I Reproduced:
1. Install cluster using latest payload
2. Run the command oc adm must-gather
3. check if must-gather has collected endpoints for all

 $ oc version -o yaml
clientVersion:
  buildDate: "2020-04-20T06:10:05Z"
  compiler: gc
  gitCommit: 4fb2d4d96e6b604f7d4ee49080238a5aec04dc4f
  gitTreeState: dirty
  gitVersion: openshift-clients-4.3.14-202004180552
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64
openshiftVersion: 4.5.0-0.nightly-2020-05-08-095803
releaseClientVersion: 4.3.15
serverVersion:
  buildDate: "2020-05-06T21:10:44Z"
  compiler: gc
  gitCommit: dfd05bf
  gitTreeState: clean
  gitVersion: v1.18.0-rc.1
  goVersion: go1.13.4
  major: "1"
  minor: 18+
  platform: linux/amd64


[parube@ip-172-31-48-186 quay-io-openshift-release-dev-ocp-v4-0-art-dev-sha256-a1fd1865f9688b923057f1215e5d4196aea5591d3a194bea05a361eb3a0f032b]$ find . -name "*endpoints*"
./namespaces/openshift-cluster-version/core/endpoints.yaml
./namespaces/openshift-authentication-operator/core/endpoints.yaml
./namespaces/openshift-authentication/core/endpoints.yaml
./namespaces/openshift-cloud-credential-operator/core/endpoints.yaml
./namespaces/openshift-machine-config-operator/core/endpoints.yaml
./namespaces/openshift-etcd-operator/core/endpoints.yaml
./namespaces/openshift-kube-apiserver-operator/core/endpoints.yaml
./namespaces/openshift-console-operator/core/endpoints.yaml
./namespaces/openshift-kube-scheduler-operator/core/endpoints.yaml
./namespaces/openshift-service-ca/core/endpoints.yaml
./namespaces/openshift-cluster-storage-operator/core/endpoints.yaml
./namespaces/openshift-kube-storage-version-migrator-operator/core/endpoints.yaml
./namespaces/openshift-multus/core/endpoints.yaml
./namespaces/kube-system/core/endpoints.yaml
./namespaces/openshift-kube-storage-version-migrator/core/endpoints.yaml
./namespaces/openshift-apiserver/core/endpoints.yaml
./namespaces/openshift-cluster-samples-operator/core/endpoints.yaml
./namespaces/openshift-network-operator/core/endpoints.yaml
./namespaces/openshift-marketplace/core/endpoints.yaml
./namespaces/openshift-ingress-operator/core/endpoints.yaml
./namespaces/openshift-kni-infra/core/endpoints.yaml
./namespaces/openshift-kube-apiserver/core/endpoints.yaml
./namespaces/openshift-apiserver-operator/core/endpoints.yaml
./namespaces/openshift-config-operator/core/endpoints.yaml
./namespaces/openshift-controller-manager/core/endpoints.yaml
./namespaces/openshift-insights/core/endpoints.yaml
./namespaces/openshift-kube-controller-manager/core/endpoints.yaml
./namespaces/openshift-cluster-node-tuning-operator/core/endpoints.yaml
./namespaces/openshift-machine-api/core/endpoints.yaml
./namespaces/openshift/core/endpoints.yaml
./namespaces/openshift-config-managed/core/endpoints.yaml
./namespaces/openshift-dns/core/endpoints.yaml
./namespaces/openshift-cluster-machine-approver/core/endpoints.yaml
./namespaces/openshift-kube-scheduler/core/endpoints.yaml
./namespaces/default/core/endpoints.yaml
./namespaces/openshift-monitoring/core/endpoints.yaml
./namespaces/openshift-sdn/core/endpoints.yaml
./namespaces/openshift-service-ca-operator/core/endpoints.yaml
./namespaces/openshift-operator-lifecycle-manager/core/endpoints.yaml
./namespaces/openshift-ingress/core/endpoints.yaml
./namespaces/openshift-controller-manager-operator/core/endpoints.yaml
./namespaces/openshift-config/core/endpoints.yaml
./namespaces/openshift-console/core/endpoints.yaml
./namespaces/openshift-etcd/core/endpoints
./namespaces/openshift-etcd/core/endpoints.yaml
./namespaces/openshift-dns-operator/core/endpoints.yaml
./namespaces/openshift-kube-controller-manager-operator/core/endpoints.yaml
./namespaces/openshift-image-registry/core/endpoints.yaml

Comment 8 errata-xmlrpc 2020-07-13 17:13:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.