Bug 1794750 - Running help for openshift-baremetal-install mentions openshift-install instead
Summary: Running help for openshift-baremetal-install mentions openshift-install instead
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.4.0
Assignee: Stephen Benjamin
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On:
Blocks: 1771572
TreeView+ depends on / blocked
 
Reported: 2020-01-24 14:27 UTC by Alexander Chuzhoy
Modified: 2020-05-04 11:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:26:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 2995 0 None closed Bug 1794750: cmd/openshift-install: use binary name for usage 2020-04-28 12:07:49 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:27:05 UTC

Description Alexander Chuzhoy 2020-01-24 14:27:09 UTC
Running help for openshift-baremetal-install mentions openshift-install instead

Version: 4.4.0-0.nightly-2020-01-23-054055

Steps to reproduce:

[kni@r640-u01 ~]$ ./openshift-baremetal-install --help|head -n 5
Creates OpenShift clusters

Usage:
  openshift-install [command]





[kni@r640-u01 ~]$ ./openshift-baremetal-install create --help|head -n 5
Create part of an OpenShift cluster

Usage:
  openshift-install create [flags]
  openshift-install create [command]


Expected result:
The command in help output should openshift-baremetal-install and not openshift-install.

Comment 3 Raviv Bar-Tal 2020-02-09 07:20:03 UTC
How can I tell in which image/version is the fix packaged?
The "Fixed In Version" field is empty

Comment 4 Stephen Benjamin 2020-02-09 15:11:23 UTC
I don't know how openshift automation handles Fixed In Version, but code merged to master lands in a nightly within a few hours. I'd test on the latest 4.4 nightly.

Comment 6 errata-xmlrpc 2020-05-04 11:26:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.