Bug 1794824 - [buildcop] release-openshift-ocp-installer-e2e-vsphere-upi-4.4 failing [NEEDINFO]
Summary: [buildcop] release-openshift-ocp-installer-e2e-vsphere-upi-4.4 failing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Joseph Callen
QA Contact: liujia
URL:
Whiteboard:
: 1797508 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-24 19:16 UTC by Cesar Wong
Modified: 2020-05-04 11:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:26:40 UTC
Target Upstream Version:
jiajliu: needinfo? (jcallen)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1425 0 None closed Bug 1794824: If PlatformStatus.VSphere is nil do not template the file 2021-02-08 10:27:12 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:27:05 UTC

Description Cesar Wong 2020-01-24 19:16:23 UTC
Description of problem:

Bootstrap of cluster never completes for vsphere UPI test:
https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-vsphere-upi-4.4/563


How reproducible:
Failed e2e

Steps to Reproduce:
1. Run release-openshift-ocp-installer-e2e-vsphere-upi-4.4 test

Actual results:
Test fails

Expected results:
Test should pass

Additional info:
It seems that workers and masters are getting an empty hostname in the ignition URL (see screenshot images):
https://storage.googleapis.com/origin-ci-test/logs/release-openshift-ocp-installer-e2e-vsphere-upi-4.4/563/artifacts/e2e-vsphere-upi/installer/compute-0.png
https://storage.googleapis.com/origin-ci-test/logs/release-openshift-ocp-installer-e2e-vsphere-upi-4.4/563/artifacts/e2e-vsphere-upi/installer/control-plane-0.png

Comment 1 Abhinav Dahiya 2020-02-07 23:22:16 UTC
*** Bug 1797508 has been marked as a duplicate of this bug. ***

Comment 2 liujia 2020-02-10 07:06:54 UTC
Checked latest ci job https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-vsphere-upi-4.4/563, the job still failed, but it's not the same with the error described in this bug. Should be another known issue https://bugzilla.redhat.com/show_bug.cgi?id=1798945.

And the problem that an empty hostname in the ignition URL is fixed now.
https://storage.googleapis.com/origin-ci-test/logs/release-openshift-ocp-installer-e2e-vsphere-upi-4.4/767/artifacts/e2e-vsphere-upi/installer/control-plane-0.png
https://storage.googleapis.com/origin-ci-test/logs/release-openshift-ocp-installer-e2e-vsphere-upi-4.4/767/artifacts/e2e-vsphere-upi/installer/compute-0.png

Master node and compute node lunched successfully. So verify this bug since original issue has been fixed, and continue track the new failure in bz#1798945

Comment 3 Joseph Callen 2020-02-10 15:40:32 UTC
For CI this also needs to change:
https://github.com/openshift/release/pull/7096

Comment 4 liujia 2020-02-11 02:47:50 UTC
(In reply to Joseph Callen from comment #3)
> For CI this also needs to change:
> https://github.com/openshift/release/pull/7096

@Joseph Callen
Is the pr for this bug? And should i checked the change in the latest ci job?

Comment 6 errata-xmlrpc 2020-05-04 11:26:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.