Bug 1794900 - [ceph-ansible] : rolling_update of containerized cluster failed searching inappropriate container name while trying to get keyrings from monitor
Summary: [ceph-ansible] : rolling_update of containerized cluster failed searching ina...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 4.0
Assignee: Guillaume Abrioux
QA Contact: Vasishta
URL:
Whiteboard:
Depends On:
Blocks: 1792122
TreeView+ depends on / blocked
 
Reported: 2020-01-25 08:10 UTC by Vasishta
Modified: 2020-01-31 12:49 UTC (History)
8 users (show)

Fixed In Version: ceph-ansible-4.0.13-1.el8cp, ceph-ansible-4.0.13-1.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:48:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 4988 0 None closed fix calls to `container_exec_cmd` in ceph-osd role 2020-03-19 08:23:59 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:49:04 UTC

Description Vasishta 2020-01-25 08:10:42 UTC
Description of problem:
rolling update is failing at task ceph-osd : get keys from monitors trying to get keys

Version-Release number of selected component (if applicable):
$ rpm -qa|grep ceph-ansible
ceph-ansible-4.0.12-1.el7cp.noarch


How reproducible:
Always (1/1)

Steps to Reproduce:
1. Configure 3.x cluster
2. Run rolling update to upgrade cluster to 4.x


Actual results:
stderr: 'Error response from daemon: No such container: ceph-mon-magna034'

Expected results:
rolling update should not fail

Additional info:

Comment 9 Vasishta 2020-01-28 05:12:33 UTC
Working fine with ceph-ansible-4.0.13-1
Moving to verified state

Comment 11 errata-xmlrpc 2020-01-31 12:48:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.