Bug 1794928 - Search Page: Removing label filter doesn't update lists
Summary: Search Page: Removing label filter doesn't update lists
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Zac Herman
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1795377 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-25 14:18 UTC by Samuel Padgett
Modified: 2020-05-04 11:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:26:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4068 0 None closed bug 1794928: Fix update label 2020-04-24 15:22:36 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:27:10 UTC

Description Samuel Padgett 2020-01-25 14:18:26 UTC
To Reproduce:

1. Go to the search page
2. Select a resource
3. Add a label filter that doesn't match anything like `foo=bar`
4. Remove the label filter by clicking on the `x` *inside* the chip. (The `x` that remove the individual label filter item, not all label filters.)

Actual Result:

The filter isn't removed, and the search result remains empty.

Expected Result:

The label filter is removed, and you can see the items.

Comment 1 Zac Herman 2020-01-27 19:50:59 UTC
*** Bug 1795377 has been marked as a duplicate of this bug. ***

Comment 3 Yadan Pei 2020-02-03 10:00:04 UTC
Follow the steps in 'To Reproduce'


The label filter can be removed by clicking the "x" *inside* the label filter chip

Verified on     4.4.0-0.nightly-2020-02-02-225006

Comment 5 errata-xmlrpc 2020-05-04 11:26:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.