Bug 1795237 - operator-registry static build fails
Summary: operator-registry static build fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Evan Cordell
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-27 14:01 UTC by Evan Cordell
Modified: 2020-05-04 11:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:27:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-registry pull 162 0 None closed Bug 1795237: Revert "fix(ci): build opm statically in CI" 2020-04-14 13:30:25 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:27:38 UTC

Description Evan Cordell 2020-01-27 14:01:36 UTC
Description of problem:
Pods created by marketplace fail with:

fatal error: unexpected signal during runtime execution
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x0]

runtime stack:
runtime.throw(0x170dbfa, 0x2a)
	/opt/rh/go-toolset-1.13/root/usr/lib/go-toolset-1.13-golang/src/runtime/panic.go:774 +0x72
runtime.sigpanic()
	/opt/rh/go-toolset-1.13/root/usr/lib/go-toolset-1.13-golang/src/runtime/signal_unix.go:378 +0x47c

goroutine 1 [syscall, locked to thread]:
runtime.cgocall(0x134a3d0, 0xc00006fde0, 0x10)
	/opt/rh/go-toolset-1.13/root/usr/lib/go-toolset-1.13-golang/src/runtime/cgocall.go:128 +0x5b fp=0xc00006fdb0 sp=0xc00006fd78 pc=0x40bc1b
crypto/internal/boring._Cfunc__goboringcrypto_DLOPEN_OPENSSL(0x0)
	_cgo_gotypes.go:597 +0x4a fp=0xc00006fde0 sp=0xc00006fdb0 pc=0x6284aa
crypto/internal/boring.init.0()
	/opt/rh/go-toolset-1.13/root/usr/lib/go-toolset-1.13-golang/src/crypto/internal/boring/boring.go:46 +0x51 fp=0xc00006fe40 sp=0xc00006fde0 pc=0x62e2a1
runtime.doInit(0x2536340)
	/opt/rh/go-toolset-1.13/root/usr/lib/go-toolset-1.13-golang/src/runtime/proc.go:5222 +0x8a fp=0xc00006fe70 sp=0xc00006fe40 pc=0x44463a
runtime.doInit(0x2535a40)
	/opt/rh/go-toolset-1.13/root/usr/lib/go-toolset-1.13-golang/src/runtime/proc.go:5217 +0x57 fp=0xc00006fea0 sp=0xc00006fe70 pc=0x444607
runtime.doInit(0x253ce40)
	/opt/rh/go-toolset-1.13/root/usr/lib/go-toolset-1.13-golang/src/runtime/proc.go:5217 +0x57 fp=0xc00006fed0 sp=0xc00006fea0 pc=0x444607
runtime.doInit(0x2535bc0)
	/opt/rh/go-toolset-1.13/root/usr/lib/go-toolset-1.13-golang/src/runtime/proc.go:5217 +0x57 fp=0xc00006ff00 sp=0xc00006fed0 pc=0x444607
runtime.doInit(0x253ee00)
	/opt/rh/go-toolset-1.13/root/usr/lib/go-toolset-1.13-golang/src/runtime/proc.go:5217 +0x57 fp=0xc00006ff30 sp=0xc00006ff00 pc=0x444607
runtime.doInit(0x2536040)
	/opt/rh/go-toolset-1.13/root/usr/lib/go-toolset-1.13-golang/src/runtime/proc.go:5217 +0x57 fp=0xc00006ff60 sp=0xc00006ff30 pc=0x444607
runtime.main()
	/opt/rh/go-toolset-1.13/root/usr/lib/go-toolset-1.13-golang/src/runtime/proc.go:190 +0x1da fp=0xc00006ffe0 sp=0xc00006ff60 pc=0x43829a
runtime.goexit()
	/opt/rh/go-toolset-1.13/root/usr/lib/go-toolset-1.13-golang/src/runtime/asm_amd64.s:1357 +0x1 fp=0xc00006ffe8 sp=0xc00006ffe0 pc=0x4634d1



Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Run a cluster
2. Look at one of the registry pods

Actual results:

Error shown above


Expected results:

No error 


Additional info:

Comment 2 Bruno Andrade 2020-01-29 15:46:17 UTC
Registry pods look healthy, marking as VERIFIED

oc get pods -n openshift-marketplace
NAME                                    READY   STATUS    RESTARTS   AGE
certified-operators-6888db7459-mz2kw    1/1     Running   0          59m
community-operators-9fcf69f96-rrbrf     1/1     Running   0          24h
marketplace-operator-7648fc7896-xld68   1/1     Running   0          24h
redhat-operators-7d649cc7f7-zdck8       1/1     Running   0          24h

Cluster Version: 4.4.0-0.nightly-2020-01-24-141203

Comment 4 errata-xmlrpc 2020-05-04 11:27:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.