Bug 1795241 - The presto-coordinator pod identifies as `presto`, needs hostAlias loopback for ipv6 to work
Summary: The presto-coordinator pod identifies as `presto`, needs hostAlias loopback f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metering Operator
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Brett Tofel
QA Contact: Peter Ruan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-27 14:10 UTC by Brett Tofel
Modified: 2020-05-04 11:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:27:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-metering pull 1081 0 None closed Bug 1795241: Add hostAliases with presto -> ipv6 loopback 2020-04-27 14:22:57 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:27:38 UTC

Description Brett Tofel 2020-01-27 14:10:36 UTC
Description of problem: Presto application starts up and tries to announce itself using the discovery-uri: presto:8080. This fails to work in IPv6 single stack.

Version-Release number of selected component (if applicable): 4.3


How reproducible: Launch IPv6 Openshift 4.3 cluster nightly build (should not matter which build). Note presto-coordinator-0 logs filled with announce failures.


Steps to Reproduce:
1. Launch IPv6 Openshift 4.3 cluster nightly build (should not matter which build).
2. Wait for presto-coordinator-o pod to come up.
3. Note presto-coordinator-0 logs filled with announcer failures.



Actual results: Presto fails to start cleanly under IPv6.


Expected results: Presto starts cleanly in the cluster under IPv6


Additional info:

Comment 2 Peter Ruan 2020-03-13 05:55:32 UTC
verified by looking at presto log there are not errors.

4.3.0-0.nightly-2020-02-06-120247-ipv6.6

Comment 4 errata-xmlrpc 2020-05-04 11:27:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.