Bug 1795305 - Virtualized table rows do not show properly on Search page [openshift-4.4]
Summary: Virtualized table rows do not show properly on Search page [openshift-4.4]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-27 16:29 UTC by Zac Herman
Modified: 2020-05-04 11:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:27:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4083 0 None closed Bug 1795305: search: use accordion component 2020-06-18 17:16:48 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:27:38 UTC

Description Zac Herman 2020-01-27 16:29:20 UTC
Description of problem:
In new expandable sections of search page results, the top rows will disappear at times.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Go to Search page
2. Select all projects
3. From multi-select dropdown, choose APIService and Services
4. Expand both sections for APIService and Service
5. Scroll down the page and notice that there are gaps at the top of the rows that should not be there

Actual results:
Gaps in the rows appear as some rows are not visibile

Expected results:
All rows should show during scroll

Additional info:
This is specific to the new 4.4 Search page

Comment 2 Yanping Zhang 2020-02-05 04:09:19 UTC
The fix pr is not contained in today's payload 4.4.0-0.nightly-2020-02-04-171905, wait for newer payload.

Comment 3 Yanping Zhang 2020-02-06 04:55:48 UTC
Tested on OCP 4.4 env with payload 4.4.0-0.nightly-2020-02-05-181112.
Now filter by resources APIService and Services for all projects, there is no gap at the top of table when scroll down the page.
The bug is fixed, so move it to Verified.

Comment 6 errata-xmlrpc 2020-05-04 11:27:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.