Bug 1795325 - Downloads deployment will fail on nodes configured with ipv6.disable=1
Summary: Downloads deployment will fail on nodes configured with ipv6.disable=1
Keywords:
Status: CLOSED DUPLICATE of bug 1846922
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-27 17:11 UTC by bpeterse
Modified: 2020-06-15 17:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-15 17:33:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description bpeterse 2020-01-27 17:11:23 UTC
The console downloads deployment was updated to handle IPv6 with a graceful fallback to IPv4 under most circumestances:

https://github.com/openshift/console-operator/pull/375/files#diff-d6f339970508d6b626a788b9035d6c48R120

There are details in the comments on that PR. 
If nodes are explicitly configured to disable IPv6 via ipv6.disable=1, then the Python script is likely to fail and cli downloads will be unavailable.

Comment 1 bpeterse 2020-01-27 17:13:02 UTC
Severity here is unknown, I think it may be fine to bump this to a non-blocking 4.4.z stream bug but will look to confirm.

Comment 2 Yadan Pei 2020-03-26 08:21:06 UTC
Hi Ben, 

Does changing target release to 4.5.0 mean this issue is not a 4.4 release blocker? Is this intended? Do we still want to fix for 4.4? 

From QE's perspective, it should be fixed in 4.4

Comment 4 Yadan Pei 2020-04-03 07:55:32 UTC
Setting severity and target release, let me know if it's wrong

Comment 5 bpeterse 2020-05-08 16:09:30 UTC
We have not addressed this issue yet.

Comment 6 bpeterse 2020-05-15 20:55:26 UTC
Bumped to 4.6, not a 4.5 priority.

Comment 8 Samuel Padgett 2020-06-15 17:33:44 UTC

*** This bug has been marked as a duplicate of bug 1846922 ***


Note You need to log in before you can comment on or make changes to this bug.