Bug 1795374 - Tiles on Tile View of OperatorHub have inconsistent text overflow treatments
Summary: Tiles on Tile View of OperatorHub have inconsistent text overflow treatments
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Steve Goodwin
QA Contact: Mike Fiedler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-27 19:29 UTC by bpeterse
Modified: 2020-05-04 11:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:27:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of visuals (36.11 KB, image/png)
2020-01-27 19:42 UTC, bpeterse
no flags Details
After fix (31.86 KB, image/png)
2020-01-31 20:21 UTC, Mike Fiedler
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4082 0 None closed Bug 1795374: Fix bug where the PF react-catalog-view applies a white gradient, along with a trailing ellipsis, to trunc... 2020-02-06 15:56:17 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:27:38 UTC

Description bpeterse 2020-01-27 19:29:48 UTC
A tile on the tile view page of OperatorHub contains inconsistent treatments of overflow text. 

- Line 1 of the text fades out to the background color (white).
- Line 2 is truncated with an ellipsis.

See attached screenshot for further details

To Reproduce:

- Visit OperatorHub page
- Search for "Couch" to get the same 2 Operators as contained in the screenshot.

Comment 1 bpeterse 2020-01-27 19:42:44 UTC
Created attachment 1655744 [details]
Screenshot of visuals

Comment 2 Steve Goodwin 2020-01-27 22:07:13 UTC
fix
https://github.com/openshift/console/pull/4082

Comment 6 Mike Fiedler 2020-01-31 20:18:26 UTC
Verified on 4.4.0-0.nightly-2020-01-31-115654

Only the ellipsis appears.  See screenshot

Comment 7 Mike Fiedler 2020-01-31 20:21:17 UTC
Created attachment 1656778 [details]
After fix

Comment 9 errata-xmlrpc 2020-05-04 11:27:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.