Bug 1795387 - The Query Browser page under monitoring flickers black when the page lists a lot of information [4.4]
Summary: The Query Browser page under monitoring flickers black when the page lists a ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Andrew Pickering
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-27 20:20 UTC by bpeterse
Modified: 2020-10-27 15:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:54:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
Animated gif of the described phenomenon (1.99 MB, image/gif)
2020-01-27 20:21 UTC, bpeterse
no flags Details
reproduced with FF 75.0 (64-bit) (5.51 MB, video/webm)
2020-06-22 09:22 UTC, Junqi Zhao
no flags Details
issue is fixed,the table is rendered as a grid (106.17 KB, image/png)
2020-06-23 07:45 UTC, Junqi Zhao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5745 0 None closed Bug 1795387: Query Browser: Remove single column table layout 2020-09-30 17:58:31 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:55:19 UTC

Description bpeterse 2020-01-27 20:20:44 UTC
Description of problem:

Enter a query that returns a lot of data, for example:
- https://console-openshift-console.apps.<your-cluster-id>.devcluster.openshift.com/monitoring/query-browser?query0=kube_pod_labels
- "kube_pod_labels"
- click "run queries"
- scroll down the page

At arbitrary intervals (10-20 seconds) the entire page, including sidebar menus, will flicker black for a moment.

Comment 1 bpeterse 2020-01-27 20:21:50 UTC
Created attachment 1655746 [details]
Animated gif of the described phenomenon

Comment 2 Andrew Pickering 2020-05-13 08:13:24 UTC
This is a performance issue with the huge number of labels rendered to the screen by this query. (It is the table, rather than the graph that causes the issue).

I am investigating possible solutions (there are several possible approaches we can take to reduce the number of labels being rendered).

I also tried with the latest PatternFly 4.0 major release, but that doesn't help.

Comment 9 Junqi Zhao 2020-06-22 09:22:41 UTC
Created attachment 1698266 [details]
reproduced with FF 75.0 (64-bit)

Comment 12 Junqi Zhao 2020-06-23 07:44:24 UTC
tested with FF 75.0 (64-bit)/Chrome 79.0.3945.130 (Official Build) (64-bit) on 4.6.0-0.nightly-2020-06-23-002207, the table is rendered as a grid, and have not found the page flickers black

Comment 13 Junqi Zhao 2020-06-23 07:45:04 UTC
Created attachment 1698399 [details]
issue is fixed,the table is rendered as a grid

Comment 15 errata-xmlrpc 2020-10-27 15:54:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.