Bug 17954 - Can't use 4.0.1 XF86Config directives after upgrade
Can't use 4.0.1 XF86Config directives after upgrade
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-30 10:43 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-02 04:59:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-09-30 10:43:48 EDT
I tried using an InputDevice section in my XF86Config to configure multiple
input device support.  This works in XFree86 4.0.1 on when I've manually
installed it (off of RedHat 6.1).  It doesn't seem to work on my laptop
after I upgraded directly from 6.1 to 7.0.

xinit still reports itself as 3.3.6.

This was a plain vanilla upgrade over a vanilla 6.1 installation (except
that vi was replaced with a custom compiled version).

I tried deleting xinit and a couple of other files (the servers) and
reinstalled just the 4.0.1 XFree* packages and ended up with the same
situation.
Comment 1 Need Real Name 2000-10-01 21:00:49 EDT
I think this may be a simple as just deleting the symlink for X in /etc/X11 with
a link to /usr/X11R6/bin/XFree86 and making sure the XF86Config is 4.0.1
compatible (from what I can tell, it is).

I can understand the need to be conservative upgrading machines (for example, if
the driver hasn't been ported yet).  Since my old server was the SVGA one (this
is a Laptop with a Neomagic 2200 chip... the laptop is a Sony Vaio PCG-N505VX),
i think maybe that's why the link wasn't removed/changed (I'll look into that).

Maybe this using the old X vs. the New X should be an explicit option (it may
have been a package choice, but I was never prompted when I jut accepted the
defaults.

I'm no longer sure this is a bug vs. an enhancement request.  Looking forward to
your assessment.

Sujal
Comment 2 Alan Cox 2000-10-02 04:59:53 EDT
A lot of the 4.x servers were a little shaky so it tends to pick 3.3.6. You can
tell the system you
want a 4.0 server preferably. Use

	Xconfigurator --preferxf4

and that should get you what you want.
Comment 3 Trond Eivind Glomsrxd 2000-10-02 23:10:24 EDT
XF86Config is for XFree 3.3..x only, XFree 4 uses XF86Config-4. Put your changes
in there.

Note You need to log in before you can comment on or make changes to this bug.