Bug 1795401 - Monitoring Dashboards: k8s-resources-cluster has performance issues
Summary: Monitoring Dashboards: k8s-resources-cluster has performance issues
Keywords:
Status: CLOSED DUPLICATE of bug 1880698
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.7.0
Assignee: Rastislav Wagner
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1804922
TreeView+ depends on / blocked
 
Reported: 2020-01-27 21:32 UTC by bpeterse
Modified: 2020-10-01 12:18 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1804922 (view as bug list)
Environment:
Last Closed: 2020-10-01 12:18:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4569 0 None closed Bug 1795401: Improve monitoring dashboards performance 2020-10-01 12:17:10 UTC

Description bpeterse 2020-01-27 21:32:32 UTC
Description of problem:

The monitoring/dashboards page has several performance issues.  Some of the cards do not render, and the page generally struggles.

Comment 1 Samuel Padgett 2020-02-09 17:30:53 UTC
The cards not rendering is tracked by bug 1799907.

The pages are generally OK except for k8s-resources-cluster, which is sluggish.

Comment 2 bpeterse 2020-02-19 21:44:10 UTC
We can rename the bug to fit that then.
Doing that before bumping to 4.5 and cloning back to 4.4.

Comment 5 Yadan Pei 2020-03-06 07:01:33 UTC
I remembered that before the bug is fixed, after selecting Kubernetes / Compute Resources / Cluster dashboard, it's very hard to switch to other dashboard, even user can't scroll up/down to view metrics on page. now after data is loaded completely, user can easily switch to other dashboard. The issue should be fixed.

Verified on 4.5.0-0.ci-2020-03-04-223611

Comment 6 Yadan Pei 2020-03-06 07:11:29 UTC
After comparing the behavior on 4.5 and 4.4, I think there's still some sluggish on 4.5 for k8s-resources-cluster dashboard.

When the dashboard is loading, scrolling on page is not very smooth and there's sluggish. 

Assign back to further check, let me know if anything wrong for my verification steps.

Comment 7 Samuel Padgett 2020-04-27 17:02:36 UTC
Lowering severity to medium as the most serious problems were previously addressed.

I think https://github.com/FormidableLabs/victory/pull/1494 can make the performance better. This requires an upgrade to a new, breaking version of Patternfly, however. We should consider deferring to 4.6 due to risk.

Comment 9 Samuel Padgett 2020-05-08 16:04:36 UTC
Assigning to Dave. The new Victory version in https://github.com/openshift/console/pull/5081 should improve performance.

Comment 10 David Taylor 2020-05-29 15:02:19 UTC
The upgrade to new Victory version is planned for the upcoming sprint.

Comment 16 David Taylor 2020-08-11 15:11:34 UTC
Reassigning to rawagner@redhat.com who will be working on converting monitoring dashboards to graphGL which should help performance.

Comment 18 Samuel Padgett 2020-10-01 12:18:18 UTC
We've made performance fixes under bug 1880698. Marking this as a duplicate.

*** This bug has been marked as a duplicate of bug 1880698 ***


Note You need to log in before you can comment on or make changes to this bug.