This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 179550 - Threading broken with current Qt3
Threading broken with current Qt3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 06:25 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 06:07:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Example program which fails to compile (6.16 KB, application/x-zip-compressed)
2006-02-01 06:25 EST, Paul F. Johnson
no flags Details

  None (edit)
Description Paul F. Johnson 2006-02-01 06:25:44 EST
Description of problem:
Using a simple test example provided in C++ GUI Programming using Qt (attached
to this bug), it appears that threading is either not enabled or broken with the
current rawhide release version of Qt.

Version-Release number of selected component (if applicable):
3.3.5-12

How reproducible:
Always

Steps to Reproduce:
1. Attempt to compile the attached code
  
Actual results:
Various errors concerning the Qt Mutex and Threading classes are generated

Expected results:
It should compile.

Additional info:

I have tested this against a sandbox install of Qt3 from the Trolltech website
and the code compiles and runs without a problem. Code compiled on an x86_64
box, untested on an x86 machine.
Comment 1 Paul F. Johnson 2006-02-01 06:25:44 EST
Created attachment 123955 [details]
Example program which fails to compile
Comment 2 Rahul Sundaram 2006-02-20 06:07:40 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks

Note You need to log in before you can comment on or make changes to this bug.